Butterfly 0.0.05 bluecfd io error

I am really sorry for disturbing,but I have tested several vision of rhino in windows 7 including rhino 6.12/6.2/6.5/6.8.
Same mistake shows in the exact same line of runmanager_bluecfd.py and case.py listed above.
when it comes to rhino 6.12/6.2 which means that there’s no need to install microsoftvisualc++2017, the error goes"Unable to translate bytes [BE] at index 0 from specified code page to Unicode" which happened in a HB issue here.

When it comes to 6.5/6.8, the error is as same as the problems listed above. I am poor in Python but may be these messages can be of little help.

Is there a fix/solution for this? I’m coming back to this on a windows 7 machine, Rhino 6, and am getting the same error as I had before.
Things I have verified on workstation:
Running Rhino 6 as admin
Blue-CFD core terminal running as Admin (environment ready).
Able to read/write to butterfly folder, (tested with simple code below)

parent_dir = 'C:/Users/chanley/butterfly/'
directory = "SomeNewDirectory"
path = os.path.join(parent_dir, directory) 

except OSError as error: 

All programs installed with default settings, (US english langauge, no other language packs being used, default directories, etc…)
Anyone have any suggestions?

is it possible that this could be related to a path issue? As in, if a user account is in a domain, sometimes the path might come back as C:\Users\chanley.DOMAIN\appdata\etc… VS C:\Users\chanley\appdata…?
Just a shot in the dark. I am also testing on a brand new windows 10 machine…but still no luck.

I am having exactly the same problem.

hi, i just meet something similar. But not exact same.

And to solve this i found the link:WindowError win32 exception · Issue #382 · ladybug-tools/butterfly · GitHub
BUT this solution will affect creating case from geometries :disappointed_relieved:

Hi @Lincy As I know,Butterfly V0.0.05 only support BlueCFD 2017-1 Version. Please uninstall BlueCFD 2020 and install BlueCFD 2017-1.

Hello Dears,
I have almost the same problem with Blue CFD and the Example file “01_0_outdoor_airflow”.

so I installed Rhino 7 but unfortunately There isnt any Grasshopper link for Rhino 7.
what can I do?

1 Like

Butterfly Version 0.0.05 only support blueCore-CFD 2017-1 Version. Uninstall blueCore-CFD-2020 and install blueCore-CFD 2017-1 Version.

1 Like

Hi everyone, I had a similar problem that butterfly was not working and giving me this error-
Solution exception:Access to the path ‘C:\Users\username\butterfly\outdoor_airflow\system\blockMeshDict’ is denied.

  1. Solution exception:‘“C:\Program Files\blueCFD-Core-2020\setvars.bat”’ is not recognized as an internal or external command,
    operable program or batch file.
    ‘blockMesh’ is not recognized as an internal or external command,
    operable program or batch file.

I found a simple solution- in the blueCFD-Core-2020 file, I had a file named “setvars_OF8” instead of just “setvars”. I copied the file and changed its name and it worked! so I hope this helps someone.