Butterfly 0.0.05 bluecfd io error

#1

Hello,

I’ve downloaded the latest version (0.0.05) of butterfly from food4rhino on Rhino 6 and Win7 64bit, installed it with the installer.gh and tested after sucessful installation the outdoor airflow example. It works fine until I activate the write option and the the run option on the blockmesh component. Then I get:

Updating cell size in blockMeshDict.
Updating grading in blockMeshDict.
Saved changes to blockMeshDict to:
C:\Users[user]\butterfly\outdoor_airflow\system\blockMeshDict
Runtime error (PythonException): Das Handle ist ungültig.
Das Handle ist ungültig.
Das Handle ist ungültig.
Das Handle ist ungültig.
Das Handle ist ungültig.
tee: failed to reopen ‘stdout’ with mode ‘wb’: Bad file descriptor

–> FOAM FATAL IO ERROR:
error in IOstream “Sout” for operation Ostream& operator<<(Ostream&, const char*)

file: Sout at line 16.

From function virtual bool Foam::IOstream::check(const char*) const
in file db/IOstreams/IOstreams/IOstream.C at line 96.

FOAM exiting

Traceback:
line 278, in _handle_process, “C:\Users[user]\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\butterfly\runmanager_bluecfd.py”
line 213, in _run_ironpython, “C:\Users[user]\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\butterfly\runmanager_bluecfd.py”
line 234, in run, “C:\Users[user]\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\butterfly\runmanager_bluecfd.py”
line 756, in command, “C:\Users[user]\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\butterfly\case.py”
line 788, in blockMesh, “C:\Users[user]\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\butterfly\case.py”
line 52, in script

when I run the ir.bat file from the “command shell” everything is fine and blockmesh starts and runs without error. Do you have a hint how to overcome this issue? It’s the same with the other examples.

thanks in advance

Gabriel

#2

@GG ,

I am by no means the the best expert of OpenFOAM errors on this forum but did you run the blueCFD-Core terminal as administrator as described in step 3 on the wiki?

Alternatively, does running Rhino as administrator address the issue?

#3

Yes, I ran both (blueCFD cor terminal and Rhino ) as Admin, but I always get this error

#4

Hi, I have the exact same error but with Rhino 5. Any inputs?
Thanks in advance!

#5

Hello,
exact same here.

  • Windows 7 // Rhino 6
  • Installed blueCFD-Core 2017-2 in standard folder
  • Open bluecfd terminal as admin
  • Reboot
  • Installed Butterfly 0.0.05 with one error: “Failed to remove C:…\UserObjects\Butterfly
  • Reboot
  • Open Rhino 6 as admin
  • Open example file 01_9_outdoor_airflow
  • Get the error when flagged true the blockmesh…
  • Went to bed sad
#6

Guys,
windows 7 was the problem…

re-done everything with win 10 and it works

1 Like
#7

Damn, ok, thanks for the update!

#8

Hello, it seems i’m having the same issue. When I am opening the Buoyancy example file in Butterfly, the blockmesh component is giving me the error message as can be seen in the attached image. Is there any other way around than changing to Windows10? (I’m running on Win7 right now) Thank you!

#9

Same problem here in blockMesh:

  1. Solution exception:The handle is invalid.
    The handle is invalid.
    The handle is invalid.
    The handle is invalid.
    The handle is invalid.
    tee: failed to reopen ‘stdout’ with mode ‘wb’: Bad file descriptor

–> FOAM FATAL IO ERROR:
error in IOstream “Sout” for operation Ostream& operator<<(Ostream&, const char*)

file: Sout at line 16.

From function virtual bool Foam::IOstream::check(const char*) const
in file db/IOstreams/IOstreams/IOstream.C at line 96.

FOAM exiting

Anyone got it solved?