Cannot import geometry from ladybug error


Unfortunately, after update (as instruced above) there are some not-working components. So far I noticed that ASE and sDA result components give same error when dropped to canvas:

  1. Solution exception:
    Failed to import ladybug:
    cannot import geometry from ladybug

I tried restarting rhino/gh and placing components in an empty file (see picture)

As noted here:

I am also having a similar issue.

Hi,@Wujo @MichaelDonn You missed some library for HoneybeePlus. Please add the library to your computer.

For those wondering, I have responded to this post here:

I’ll take a look later today or tomorrow morning and will push a fix as needed. Sorry for the issues that happened with the update.

We’re discussing a better way to test our Grasshopper plugins similar to the core libraries.

HI Mostapha

First: hope you and your family are well.

In relation to this post, does this mean I am correct that the only fix available is to wait until the library addressing issues are sorted, or is there a workaround?

kia kaha


Hi Michael,

Thanks! We are well. I hope the same for you and your family.

Your assumption is correct. The good news is that I just fixed the issue. I will add my reply shortly.

1 Like

I updated the components and the sample files. If you user the updated to update the components it should now work fine.

1 Like

Thank you SO much.

I updated the installation of Honeybee/Ladybug.

I then ran the file updater on the old example file - and the error persisted.

I then tried downloading your version of the updated script, It ran perfectly.

A great starting point for an exercise I am planning to illustrate for students of what you can learn from the various metrics.


Hi all,

I’ve been following the discussion closely and have implemented all the proposed fixes, but am still unable to get the example files to work. I have updated hb+ with the new update component and use the new sample files.

Now the errors are primarily in two components:

  1. LB Generate Point Grid:

    1. Solution exception:len() of unsized object
  2. LB Spatial Heatmap:

    1. Solution exception:attribute ‘TextHorizontalAlignment’ of ‘namespace#’ object is read-only

Screenshots of the full errors in the attachment.
Thanks in advance.