DF error - Cannot load such file openstudio/common_measures


I was trying Dragonfly urban energy modeling for my model and observed Urbanopt showing error for simulation.

Then I tried the sample files and found the attached error after a long time. Any idea how to resolve it?


I changed my path and other measures previously mentioned in other related conversations.


Error: After making a new model and attempting to simulate it

Hi @Naga ,

Sorry for the late reply. I am pretty confident that your issue is the same as the one that was solved here:

So just follow the instructions there and feel free to post back here if it does not solve your issue.

Hi Chris, I tried all the possible solutions but couldn’t succeed. So, temporarily I stopped my work related with Dragonfly. :slight_smile:

Hi @Naga ,

I’m sorry that I was not able to help earlier when you first encountered the issue. Looking again at your original screenshot, you were definitely experiencing the bug that I linked to, which can be solved by running the LB Versioner. If the simulation is still not completing after running the versioner, manually deleting the URBANopt project folder, and restarting Rhino, then it’s possible that you’re experiencing another issue after solving the first (perhaps related to the validity of the Dragonfly Model).

I realize that you probably have other work but, if you’re able to find the time to upload your Grasshopper definition that is building your Dragonfly Model, I’m confident that we can figure out what is going wrong and get it running for you.