EPW files from Meteonorm not working?

Hello there, just wanted to check whether there could be any issue with regards to using epw files coming from Meteonorm instead of those in EnergyPlus webpage.

Were I to replace the latter with the former, an error would come about. No other changes made, just the EPW. Could there be any workaround to it? Maybe there’s additional programming required before running it?

Kind regards,

cc @SaeranVasanthakumar
I have not used UWG in a long time. Is it the white space in the file name?

1 Like

Do files downloaded from EnergyPlus website work fine?

1 Like


I agree with @devang, I suspect it’s the white spaces in your directory and file name. Can you change that and see if it works?

1 Like

Hello there guys, thank you very much for your reply;

Well, indeed EnergyPlus native downloaded files do work perfectly fine in contrast to those coming out of Meteonorm.

I’ll have a look at the white spaces you mentioned in the directory and confirm whether that could be the issue with the malfunctioning this time.


Well… Apparently, eliminating the spacing in the path won’t do anything on fixing the issue :frowning_face:

@LVD Could you upload the epw file for further testing and debugging?


Also, could you copy and paste the error message from the readMe output?

Sorry for the delay guys, I only recently managed to get back down onto the project.
I´m afraid I’ll be unable to upload said weather file, as a forum message log states that since I’m a new user I am therefore forbidden to attach any files other than pictures.

I will include the error prompt, nontheless. Hope it’s of any use


you can use wetrasfer to upload the file and share a link here

Good idea, never thought of it. here you go

@LVD It is a simple bug in the name of this epw file. You should change the space to low line for this file . Here is the solution for you.

1 Like

Thank you for taking the time for checking that out, man. :slight_smile:

Unfortunately I already tried that. There seems to be an issue with the UWG node, rather than Ladybug’s ability to read such weather files.

I noticed that native EP files and Meteonorm files are written in a slightly different way, should you compare them after opening them as text files.

@LVD Could you share the your grasshooper file?


It looks like it’s failing at when trying to read the precipitation column in the weather file. Does your Meteonorm lack precipitation data?

See this post on how to fix it: UWG not working with Morphed Future projection (2050) data without precipitation or specific humidity


1 Like

Yes! That post much does seem to refer to the very same sort of error. I will try that later and keep you posted on the results.

Thank you very much for your help.


Saeran, you were right, adding that to the EPW file has effectively solved the problem.

I cannot thank you enough guys, to each one of you keen on helping me out.

Hope you’re doing awesome!