Error during startup. Component missing

Hello everyone.

I have been getting an error every time I open one of my honeybee definitions. It basically regarding the honeybee_Itemselector


Ever since this error came up, the item selector has been missing. I tried uninstalling and deleting all the files - then reinstalled , but the item selector is still missing.

Any ideas how I can get it back?

Thanks in advance

Hi @FabianPosadas, you might have mistakenly copied it to userobjects folder instead of libraries folder. Here is the gha file. Make sure to unblock it after downloading the file.

ItemSelector.gha (29.5 KB)


Thank you Mostapha! That was it

Hello mostapha
I did and it still does not work!!!
I cant find honeybee_Itemselector

@roya After copying just go to properties and check box on unblock.

Just to flag, ItemSelector didn’t install when I installed the latest version of ladybug tools a few days ago. I’ve downloaded and installed the gha file that Mostapha posted above and this worked. I’m unsure why it wouldn’t have installed with v 1.1.0. I did need to mannually add laydbug tools to the rhino python path, not sure if this would have had something to do with it.

ItemSelector it is part of legacy toolset, but isn’t included in the new Ladybug Tools. If you didn’t install the legacy plugin, you won’t have it. You can also get it by installing another plugin Human