How to Manually Add Ladybug Tools to the Rhino Python Path

Several users have been trying to install the new Ladybug Tools plugin using the Food4Rhino installer but they have never used GHPython in Grasshopper (or Python in Rhino) before and so they lack the settings file that the installer tries to edit. This results in the failure of the last step on Windows - running the set_python_path.bat and users experiencing all Ladybug tools components returning the error:

Failed to import xxx: no module named xxxx

While our primary recommendation for this case is to just purchase an executable installer by emailing info@ladybug.tools, there is a manual workaround if you are willing to spend more time to implement it. It is as follows:

  1. Make sure that the following directory exists on your machine after following all of the previous installation steps:
    C:\Users\[USERNAME]\ladybug_tools\python\Lib\site-packages

  2. Open Rhino and type the EditPythonScript command into your command bar. This will bring up the following window:

  3. Select Tools > Options from the menu bar at the top. This will bring up the following window:

  4. Click the button highlighted in Green above, which is labeled “Add to search path” and allows you to add a new path to Rhino Python.

  5. This will bring up a menu where you can navigate to the site-packages folder noted above like so:

  6. Hit OK for all of the windows you opened and close Rhino.

  7. The next time that you restart Rhino/Grasshopper the Ladybug Tools components should work without import errors.

13 Likes

Thanks Chis. It worked perfectly.

It worked perfectly ! Thank you Chris

I’m not sure why, but I don’t have a pyton folder in this location. How does one fix that issue?

Thanks chris. it worked perfectly!

Thanks Chris! Resolved the issue

Thanks, It worked.
Before this, although I was going through all of the installation guid steps, I was receiving this error:
Solution exception: Failed to import honeybee: No module named honeybee.hbsurface

This one worked for me

Hi Chris, this works fine for me. Thanks very much!

thanks
it worked perfectly,
just one question, I’m missing some icons like radiation rose how to find them?

Hi @chris,
I needed to do this in two computers because it didn’t work normally in any of them and the process works in both cases.
But in my computer once I try to runrecipe in the example for the Daylight factor (after installing radiation and openstudio) the window of the queenbee open an closes without giving any result of the analisys.
Do you have any idea what could be happening?

Thank you Chris :slight_smile: It works for me too.

Radiation Rose is not yet in the LBT plugin. It should hopefully be there in the next stable release.

1 Like

Thanks for clarification, anyway I downloaded the legacy version.
Keep the great work

Thank you for your workaround, however I do not agree with:

I find that hard to believe. APPDATA is like a default environment variable in Windows. If I enter %APPDATA% in the address bar of Windows Explorer, it goes to C:\Users[USERNAME]\AppData\Roaming
If I type echo %APPDATA% in the command prompt it returns C:\Users[USERNAME]\AppData\Roaming

I tried to install the new Ladybug Tools 1.1.0 on two laptops and one desktop computer and all failed. I think something is wrong in the installer.

Hum, installer worked fine for me after I got admin rights to my computer. It was impossible to install before and what Chris showed seems to be exactly the workaround. What is the issue you are getting into when installing?

Great guy @chris
seems to work now. can’t wait to experimenting with the latest LBT version.

A post was split to a new topic: Rhino crashing when dropping honeybee components on the canvas

Thank you @chris, that fixed the issue for me.

In all my cases, having admin rights on my personal laptops and desktop, I first had to add C:\Users\[USERNAME]\ladybug_tools\python\Lib\site-packages in Rhino Python options to get set_python_path.bat running properly and to get Ladybug Tools components working in Grasshopper.
In my cases Ladybug Tools is not automatically added to the Rhino Python Path. I had to add it manually.