Error HB PMV comfort map Sample file

Hi, I am receiving the following error while running the PMV comfort map sample file.
I checked old topic about similar error and I used LB versioner but, it didn’t work.
Can anyone please help me out.

The full report text:

Runtime error (PythonException): The recipe failed to run with the following summary:

Scheduled 35 tasks of which:
* 21 ran successfully:
    - 1 CopyGridInfo(...)
    - 1 CopyRedistInfo(...)
    - 1 CopyResultInfo(...)
    - 1 CreateDirectSky(...)
    - 1 CreateDynamicOctrees(...)
* 2 failed:
    - 1 CreateViewFactorModifiers(...)
    - 1 RunEnergySimulation(...)
* 12 were left pending, among these:
    * 12 had failed dependencies:
        - 1 LetPmvComfortMapFly(...)
        - 1 RestructureConditionIntensityResults(...)
        - 1 RestructureConditionResults(...)
        - 1 RestructureCspResults(...)
        - 1 RestructureHspResults(...)

This progress looks :( because there were failed tasks

Use the report_out attribute of recipe settings to see a full report.

  line 191, in script

logs.log (105.9 KB)

same problem here, would appreciate a solution @chris


Hi @naegelin, welcome to the forum

Are you able to run a simpler case? This is a good test case

If that doesn’t work you can share error message, but it’s likely an installation issue - I would remove all of ladybug tools (old and new versions, in various locations), uninstall radiance and openstudio and once you’ve got everything as clean as possible install using the Pollination one click grasshopper installer.

Hi @charlie.brooker, thanks for the warm welcome :slight_smile:

Same error as OP had, I’ll try to uninstall everything, but I just updated Ladybug with and all the external programms and double checked everything allready. I’ll keep you updated.

1 Like

So @charlie.brooker, I’m using now pollination and get the same result with your file and the other example file. Any suggestions?

sample file: outdoor_comfort_under_a_tree

sample file: comfort_mapping

I’m guessing you’re running Pollination locally rather than on the cloud? I’d be interested to know if it works on the cloud.

The sample under a tree file works for me but I’m running an older version of LBT, OpenStudio and E+. The error seems to be on the energy side, so it could be a versioning problem, or something else going wrong with your installation.

1 Like

Testing on Pollination cloud also runs fine for me

It was too obvious for me to check, but I never considered that solution… anyway, everything works perfectly fine now.

For everyone else running into that problem, I will summarize the solution I had to do to get it running:

  1. only if ladybug was previously installed manually before) delete all relevant files in C:\Users\xxx\AppData\Roaming for the components and wherever you installed EnergyPlus, OpenStudio and all other external programs (standard path is C:.)

  2. Download and install the pollination plugin from: Pollination Cloud App

  3. Downgrade ladybug to 1.5.0 with the LB Versioner component and restart Rhino

  4. Check your needed OpenStudio and E+ version, download and install: 1.4 Compatibility Matrix · ladybug-tools/lbt-grasshopper Wiki · GitHub

  5. Delete all files in C:\Program Files\ladybug_tools\openstudio and replace with correct version.

  6. Delete all files in C:\Program Files\ladybug_tools\openstudio\EnergyPlus and replace with correct version.

Everything should work now. The versions should be the same as in the last photo from @charlie.brooker

Bonus: Always run Rhino as an administrator and restart frequently.

Thanks @charlie.brooker for your help a lot!


Hi @naegelin ,

Sorry for the late response here and thanks for reporting but people should only have to do the first two steps you listed there (steps 0 and 1) in order to run comfort maps correctly. I just installed the latest version of Pollination Rhino from the link and the PMV comfort mapping sample is running fine for me.

I also looked deeper into the log file originally posted by @RikuSHINYA and it’s clear that the Honeybee model was not suitable for energy simulation as it contained a degenerate Room. You can see this in the log file:

I’d infer that this happened as a result of not paying attention to the units of the Rhino model, resulting in a room that was only a few millimeters in dimension.

To help people in the future who have a failure occurring on the RunEnergySimulation step, I recommend running your model through the HB Model to OSM component. The message out of that component can give you more information about why your Honeybee model might not be suitable for energy simulation and what exactly went wrong. This will include explicit messages about your current Rhino model units.

1 Like

FYI, we now know that almost everyone who experienced this error had it because they did not check their Rhino model units and were simulating Rooms that were a few millimeters in length. LBT 1.6 includes an explicit check for the units so that we hopefully won’t get this reported here again.

1 Like