Error in installation

Hi, I am having an error when installing ladybug, I believe it’s because my C:/ users/ 颜灏 file name is madarin. I am searching to change the user folder name but do not want to break the software on my computer. And I do not want do change my windows registry file. I am not good at computer. One question I have is if I can install ladybug to a custom folder location instead of C:/ users/ 颜灏.

Installing Ladybug Tools core Python libraries.
Installing lbt-dragonfly==0.7.127 via pip using
Ladybug Tools core Python libraries successfully installed!

Installing Ladybug Tools recipes.
Installing lbt-recipes==0.10.0 via pip using
Ladybug Tools recipes successfully installed!

Installing ladybug-rhino Python library.
Installing ladybug-rhino[cli]==1.28.6 via pip using
Ladybug-rhino Python library successfully installed!

Runtime error (EncoderFallbackException): ‘ascii’ codec can’t encode character ‘\u989C’ in position 13: ordinal not in range(128)

line 296, in write_iron_python_batch_file, “”
line 489, in script

You can do this with our single-click executable installer that we sell (not the free Food4Rhino installer). However, if you are willing to just create another user account on your machine with a username that has only ASCII characters, this would also solve your case and you would not have to buy the installer from us.

Particularly if you’re in a situation where an IT department controls your machine and you are not able to create another user account, then you can buy the installer from us by emailing

Hi Chris,

Thank you for the assistance

I managed to edit the python script of the installer and changed the installation folder to my C:\ladybug_tools. Things are working fine with most of the ladybug components, e.g., nothing used to work before I changed the python script of the installer, but now components like " LB Direct Sun Hours" are working fine.

However, some components are still having trouble, e.g., when I enter the url of the weather file to the “LB Download Weather” component, I get the ‘ascii’ codec can’t encode character error. Providing a folder solves this particular problem. However, I am stuck now with a problem in " HB Annual Daylight" which reports the below error

Runtime error (ValueErrorException): Input “sensor-grid” was not found for recipe “annual_daylight”.

line 168, in input_value_by_name, “C:\ladybug_tools\python\Lib\site-packages\lbt_recipes\”
line 94, in script

I would be grateful if I can get your feedback, and if you can point me in the direction of solving this problem. Solving the “HB Annual Daylight” component problem will help my work a lot (at least for the time being), I am sure everything else in my model is built correctly.


@yh383523210 ,

Running the following from command line should allow you to use the installation that you have in C:\ladybug_tools just like it was in its default location.

C:\ladybug_tools\python\Scripts\ladybug.exe set-config ladybug-tools-folder C:\ladybug_tools\

The annual_daylight error sounds like you just have a very old version of the software. Did you use the latest LBT 1.3 installer in your hack?

Thanks a lot for your help, the command line worked, it solved the “LB Download Weather” component issue. However, I now have a different problem with the same “HB Annual Daylight” component
(below). I would be grateful for your help.

Yes I am using the latest lady-bug tools

0. Runtime error (PythonException): The recipe failed to run with the following summary:

Scheduled 26 tasks of which:

  • 13 ran successfully:
    • 1 CreateDirectSky(…)
    • 1 CreateOctree(…)
    • 1 CreateOctreeWithSuns(…)
    • 1 CreateRadFolder(…)
    • 1 CreateSkyDome(…)
  • 1 failed:
    • 1 DirectSunlightLoop(…)
  • 12 were left pending, among these:
    • 3 were missing external dependencies:
      • 1 AnnualDaylightRaytracing(…)
      • 1 AnnualDaylightRaytracingLoop(…)
      • 1 DirectSunlight(…)
    • 6 had missing dependencies:
      • 1 CalculateAnnualMetrics(…)
      • 1 LetAnnualDaylightFly(…)
      • 1 MergeRawResults(…)
      • 1 OutputMatrixMath(…)
      • 1 _AnnualDaylightRayTracing_4fe81c3cOrchestrator(…)
    • 3 was not granted run permission by the scheduler:
      • 1 AnnualDaylightRaytracing(…)
      • 1 AnnualDaylightRaytracingLoop(…)
      • 1 DirectSunlight(…)

This progress looks :frowning: because there were failed tasks

Use the report_out attribute of recipe settings to see a full report.

line 137, in script


There was a bug related to this that resulted from usernames that contain white spaces. The latest installer on Food4Rhino has the fix. So I recommend just downloading the latest installer and then reinstalling.