Error on re-run OSM component: "1. Solution exception:expected Path, got str"

Hi everyone,
I’m having a problem when I plug in a list of OSM file addresses in Honeybee_Re-Run OSM Component.

I’ve tested this on VER 0.0.65(JAN_01_2020) and 0.0.64 (2018-Dec-10) of the component on two different computers and both rhino 5 and 6 and I got the errors every time.

A similar issue has been discussed earlier in here. but as @chris suggested, this one is different from that, so I’m posting it here under a new topic.

Can anyone help me with this issue?


You are using an older version of the component. The fixed version should be dated Dec, 04 2019

1 Like

@mostapha ,
Thank you for your response,
I tested the latest version of the component ( VER 0.0.65(JAN_01_2020)), but I get errors again:

@Nimafo, thanks. Can you also clarify what version of OpenStudio do you have installed on your machine?

1 Like

@mostapha,
Sure, It is version 2.9.1.

I changed the version of my Open Studio to 2.5 as it has been suggested here, and now it works fine.

@mostapha thanks for the hint. :slight_smile: