exporttoOpenStudio htmlReport as GJ not Kwh

openstudio

#1

Hi everyone,

The Energyplus component shows “Kwh” units in htmlReport, but openStudio Component report shows in “Gj”.
I want to know is it possible to change result unit in htmlReport when using exportToOpenStudio component?


#3

You can do it manually. Go to the project folder:
C:\ladybug\unnamed\OpenStudio\unnamed\ModelToIdf
Open up the “in.idf” with a text editor and go to the bottom of the page and change the output control table style to “JtoKWH;”.

image

Then use the Honeybee rerun IDF component to get your updated HTML output


#4

Scratch what I said previously, you can use an openstudio measure

You just need to download"Set output table Units to IP" from the building component library. Then follow this tutorial published by @mostapha on youtube to correct errors when loading measures.
Easy as pie!


#5

@FabianPosadas Thank you for your guidance. I tried to follow youtube tutorial. But I still could not figure out how measure file should be pre-processed. In YouTube, Mostapha tried to update measure in OpenStudio. Can you elaborate more what should be done for measure file?


#6

This is Great @FabianPosadas! Thank you for your help and sorry for the delayed response.
I tried Edit IDF and re-run. I will try this method ASAP. I think OpenStudio measure is more useful.:+1:


#7

Hi @KatsuyaObara and @hdimor.mr I am not in front of my station. But it was pretty simple following mostapha’s tutorial. I don’t remember if I had to do anything else. But I will check to see what I did.


#8

Excellent use of measures, @FabianPosadas !

I’ll also recommend this example file, which explains how to apply a measure to the OpenStudio model:
http://hydrashare.github.io/hydra/viewer?owner=chriswmackey&fork=hydra_2&id=Apply_OpenStudio_Measure&slide=0


#9

@FabianPosadas @chris It worked in some way! I could pre-process the measure and specify input JtoKWH. However, I want to keep SI unit but they changed to Inch-Pound unit as shown below image. How I can specify Keep SI unit and change JtoKWH?


#10

Yes, @FabianPosadas, @chris, and @KatsuyaObara It works for me but, It doesn’t create an HTML file after running:


#11

@hdimor.mr ,
It looks like your simulation did not run and it might be an issue with your starting model (not the measure). Does it work for you if you use the workflow in the example file that I posted instead of the Apply Measure component?


#12

Yes, @chris, It works perfectly:


But I think it does not account for this measure:


#13

@hdimor.mr ,
Unfortunately, the measure can’t be saved into the .osm like that. However, when you run the OpenStudio simulation from Grasshopper with that measure connected connected to the Export To OpenStudio component, the measure will be applied to the simulation.


#14

@chris,
Thanks for your attention, As your suggestion, I connected to OpenStudio component But It doesn’t work:


err.txt (1.4 KB)

Is there something that I am missing?


#15

@hdimor.mr,
Are you using OpenStudio 2.5 ?
If yes, install OpenStudio 2.4.0 or an older version, the measures should work fine with previous OS version.


#16

@OmidmRashidi, This is great!
Yes it works perfectly after I changed openstudio V to 2.4.
And I did it in Both methods :slightly_smiling_face: :


Thank you!!