Failed to write for runradiance

Hello friends
For daylight analysis on HoneyBee Plus, when I turn on the toggle to write the sky matrix, the Honeybee completely freezes and locks up. I also changed the grid base to a larger value, but again this problem was not solved. Is this problem related to Windows or hardware?

@Aliarch ,

Can you upload a minimal sample file that’s needed to recreate the issue? You might just be simulating more objects than you intended and it’s taking too long to write the files.

Thanks @chris for the quick reply
I internalized the files and uploaded them here.
I created a new file and re-created the project there And the problem was solved, but after running three times, honeybee froze again. I guess the problem is with the geometry that I give as input to the test point (I made this geometry in the Rhino environment with the split command). Of course I doubt it.
Please check the file again.
thank you very much I’m waiting for your answer.
annual daylight (531.2 KB)
daylight.3dm (325.1 KB)

@Aliarch ,

This sounds like you are hitting some limitation of the amount of data the Grasshopper UI can hold. This is partially our fault as developers since Honeybee[+] was developed in a way that relies heavily on Grasshopper’s IronPython and, as a result, it does not scale well. This is a major reason why the new LBT honeybee executes all of the recipes using a separate version of cPython that runs independently of Grasshopper.

Until we have all of the recipes in LBT honeybee complete, the best suggestion that I can offer is to break down your study into a few studies if possible. Otherwise, you can hang tight until we have the recipes in the LBT plugin.

1 Like

thanks a lot @chris
the problem was solved

1 Like

Hello, I have a problem similar to this, if I could please get some feedback, that would be great! Link to my topic:

@Aliarch @chris I have a problem similar to this, I am hoping to get some feedback, please see my topic:

1 Like

Create a new file in Grass hopper and move your project to it. The problem is solved.
If the problem persists, rewrite the algorithm in the new file.

good luck

Thank you !!! I will go ahead and rewrite it right now, and will get back to you. Was this problem solved in the past 5 days? I updated it not that long time ago and was still not working.

No, this topic is pretty old… I guess your problem is not from performance of Honey bee and Ladybug. However, such problems are usually solved by trial and error.
I think you can uninstall Honeybee and Ladybug and reinstall it and then rewrite the algorithm.

How can I uninstall them? do I just delete the folders they are located at? the parameter is from Honeybee + tho, I have tried everything but the uninstall and install.

you can take a look at my problem on this topic:

Yes I saw. Ladybug Library files on your C drive are probably missing. You definitely need to update honeybee and ladybug that in this forum explained it entirely. And if you do that, there is a 99% chance that the problem will be solved.

I uninstalled everything, but now, when trying to install, it gives me this error, would you be able to help me?