GlareAnalysis and FalseColour Components not Working


I’ve been facing these 2 issues for a while now.

1.) The GlareAnalysis component cannot seem to be able to find evalglare.
I get the following error message:

I went through the tips discussed in this link ( and double checked that my PATH & RAYPATH variables are correct. I also double checked that evalglare.exe is not locked, and I run Rhino as admin.

I am using Evalglare 2.03


2.) The FalseColour component writes the FALSECLR.BAT and HDR2TIFF.BAT successfully, but cannot execute it from inside grasshopper. I have to manually run these bat files from outside grasshopper.

Due to the nature of these errors, I get a feeling that something is not right with my grasshopper itself, but since I am able to run everything else apart from these components, I doubt that. Any hints on how to fix these issues would be highly appreciated!

Hi @MohammadHamza,

This looks like an admin issue. Both of the file are executable and there is a chance that Windows blocks the execution if you’re running it with a different level of privilege. What happens if you try to run Rhino as non-admin?

Thanks for your quick reply Mostapha.

I tried running Rhino both as an admin and without, does not fix the issue.

However, diving deeper, I managed to find the solution for problem 2 (BAT files not running). For some weird reason, the bat execution lines in the code were commented out (See below)

Line 192 is commented out by default in FalseColor component

Line 132 is commented out by default in HDR2TIFF component.

Uncommenting these lines fixes the problem. However I fail to understand why these are commented out at the first place for my machine!? I am using the latest version of HB (0.0.63). I removed old versions before reinstalling this new one. Also tried updating these components again trhough Honeybee_UpdateHoneybee. This is just so weird! My machine is getting old I guess :stuck_out_tongue:

However, I am still unable to fix the evalglare problem. I looked up the code for GlareAnalysis component and I can’t understand line 168 (see below)

Why the "/c " before to ‘hb_RADPath + “\evalglare -v”’ ? Shouldn’t ‘hb_RADPath’ variable already include the ‘C:’ ? Because when I print the string in the runCmdAndGetTheResults I get the following:

“/c C:\Radiance\lib\evalglare -v”

which makes me wonder why the extra "/c " ?

However, unfortunately even removing this "/c " doesn’t solve the problem and I still get the error that ‘failed to find evalglare…’

I wonder what I am doing wrong…?

Seems like something mixed up, hb_RADPath should be pointing to .\Radiance\bin\ as evalglare.exe is in .\bin\

And for other question:

1 Like

Because they are replaced with runCmdAndGetTheResults which uses subprocess.Popen to execute the command:

I second @vhoang’s comment on evalglare path.