HB model to OSM Error——Solution exception:expected string, got NoneType


I am a novice and just started to learn ladybug. When I was doing building energy simulations, I encountered some problems. It seems that there are some mistakes in “HB model to OSM”. It said that “Solution exception: expected string, got NoneType”. I don’t know how to solve them.
(I want to attach my gh.file, but new users can not upload attachments, sorry for that.)

If you can help me solve this problem, thank you very much!

Hi Chaneyli,

I have the same problem. Have you been able to solve it?



So I was able to make it work and I think my solution can work for you as well.

So basically I had changed the location of the ladybug_tools folder in the .gh installation components and apparently it needs to be on your user folder for ModelToOSM to work (everything else was working fine).

It looks like your ladybug_tools folder is in the users folder, but there are 2 ladybug_tools folder: one inside the other. So I think your ladybug_tools directory should look like: C:\Users\cryst\ladybug_tools… instead of C:\Users\cryst\ladybug_tools\ladybug_tools…

I would try uninstalling Ladybug, deleting this folder and re-running installation.gh.

Hopefully this works!


Your suggestion makes a lot of sense.
I actually downgraded the version to solve the problem. I think I can try to reinstall ladybug and delete the folder.

Thanks for the suggestion! :smile:


It looks like the plugin was unable to find an EnergyPlus installation. You can always use the “HB Config” component to check which simulation engines you have installed and where they are on your machine.

same error. tried your suggestion with the “HB Config” component. the only missing part is hb_os_gem. any new suggestion to solve this problem? how to set hb_os_gem

I’m not sure how you are missing that one. I would just rerun the latest installer from Food4Rhino and that should ensure that you get the gem.

that’s true. thanks a lot