I downloaded your *.ghusr file to find no-convex surfaces but it does not seem to work. To test it I took a simple box and inputted is a close box brep or as individual surfaces as BREP or SURF but it crashes.

Is it functional?


is there any new news on getting the find non-convex file to work?



Hi @kennethwmartin,
Can you please share the brep you are trying to scan for non-convex surfaces?

nVidia II Shell.3dm (717.6 KB)

This is a large building with a crazy shape. I need to find the non-convex surfaces in it.

I tested find non-convex program on a simple box and it crashed then as well. Regardless, I think the non-convex surfaces in this building are very subtile. I can not find them visually.

Any help from you would be great.



Hi @kennethwmartin,
Thank you for the file. The component ran quickly enough (4.5 seconds) on my machine. Please find the file attached.

nonConvex_Scan.gh (562.4 KB)

This component can be found in 00 | Honeybee tab.
Are you using the same component Ken?


OK… I think I am getting close. i found the block in 00-Honeybee that does the find non-convex items but it did not run for me.

I found that my Honeybee-Honeybee is yellow and it tells me that I dont have Therm 7.5 or higher installed. I loaded Therm 7.6 but Honeybee Honeybee still does not recognize that I have Therm.

Can that be why I am not finding my non-convex items?

regardless, how do i get honeybee honeybee to find that I have Therm 7.6 on my computer?


Can you please post the output of the Honeybee_Honeybee component?

It’s highly unlikely. Still, we should get you to have all the necessary installations for Honeybee_Honeybee to fly.

You install Therm from this page. If you have already done that as you have mentioned and Honeybee still doesn’t recognize the installation, then this something new we are encountering.

Also, did you check this?


I have removed my previous version of Therm, upgraded Window to the latest version then loaded the latest version of Therm. I still get the same failure in Honeybee Honeybee

I read somewhere about a “first time” you run Honeybee Honeybee where it collects data different from later runs of that block. Could that be the issue? I had discovered that I had not installed Therm prior to my first run of Honeybee Honeybee. If so, how would I correct this?


is this the latest version of Find Non-Convex?


Yes. It is the latest version.

Alright. On my machine Therm 7.5 is installed on the following directory C:\Program Files(x86)\LBNL\THERM7.5

Can you please try installing on this location on your machine?

I had installed Therm7.6 which went in to C:\Program Files(x86)\LBNL\THERM7.6.

Shall I remove Therm7.6 and simply install Therm7.5?

or… simply load Therm7.6 into a folder named Therm7.5?


I confirm that the Therm installation has nothing to do with the isConvex component. I uninstalled the Therm from my machine and the component works just fine as I expected.

Oh… that is a problem then. can you send me your Honeybee file and I will try to open it here to see if there is some subtle difference.



I down loaded Therm7.5 in stead of Therm7.6 and Honeybee Honeybee no longer had the error. I presume that the code looks for Therm7.5 specifically.


Sure. Please find the file attached.
nonConvex_Scan.gh (560.4 KB)


Good news. I simply went to your site and downloaded all the latest user objects for Honeybee and Ladybug. When I ran a fresh Rhino execution and Grasshopper the Find_non-convex user object worked. I can only assume I had some defective files.

Thanks again for all your help. You were a life saver!


Glad that worked Ken!