Honeybee is not detecting OpenStudio

Hello! I recently worked through the Honeybee tutorials on YouTube (using Ladybug Legacy and Honeybee Legacy), and I’m having trouble connecting OpenStudio to the Grasshopper interface. The error popping up in my code says, “You do not have OpenStudio installed on your system.” I have version 3.1.0 installed on my PC, so I’m not sure if I am missing a step where I can connect the two interfaces. I tried copying and pasting the two files from the “lib” folder to “CSharp>openstudio”, but it didn’t make a difference. My goal is to connect to OpenStudio to use the EnergyPlus functions in Honeybee.

I am very new to Grasshopper and would appreciate any advice!

Legacy version of plugin is not compatible with OpenStudio 3.1. you can find more information HoneyBee v.0065 cant find OpenStudio 3.1.0 :(( - #5 by furtonb


Thanks for posting the correct answer, @Teja5zz . I can confirm that too much changed in the way that EnergyPlus reports outputs between OoenStudio 3.0 and 3.1 and it just didn’t seem worth hacking the legacy plugin to get it to be partially compatible with 3.1. You’re much better off sticking with OpenStudio 3.0 and below for Legacy and you should use the newer LBT plugin if you need access to a feature in OpenStudio 3.1 and above.


Thank you both for the clarification, @Teja5zz and @chris ! I’ll install OpenStudio 3.0 and hopefully my issues will be resolved.