Honeybee not able to find installed Therm file location

therm
installation

#1

Hello everyone,
I have wondered on post at the forum and couldn’t find anyone with the same problem as me, maybe is a simple issue, but I couldn’t manage it.
I have already therm installed on my machine, but honeybee doesn’t seem to find its file path. I had the same problem with radiance, but I reinstalled directly in C:/ directory and now it works fine. However, I am not able to choose the file location to Therm. It creates a file at C:/Programfiles(86x)/lbnl/therm. I have reinstalled therm a couple of times and it doesn’t seem to change anything.
This is the menssage that Honeybee tells me:

Does someone know a way so I can rewrite the path to Therm on Honeybee, or a way to change the Therm directory location?

Thank you


Honeybee_find_nonconvex
#2

If you installed the newest THERM, then you need to update the Honeybee.


#3

Yeah I don’t this is a file path issue, you have THERM installed in the correct location, HB should find it.


#4

Thank you Peng,
worked perfectly


#5

I countered the same problem even I was using Ladybug 0.0.65 and Honeybee 0.0.62. Also, I just updated to the legacy version but the problem is still there. To mention it, I had installed THERM7.6 before I update my Honeybee to the Legacy version.

THERM7.6 is automatically installed to C:/Users/Public/LBNL2


#6

@MingboPeng what do you suggest in this case?


#7

Hi @HardiBarznji , you just need to update your honeybee, it will fix it. this is because your THERM is newer than honeybee.


#8

Thank you for the reply @MingboPeng. I understand your point, but it there a newer version than Honeybee 0.0.62 (Legacy version)? I have this one which I think it is the last update!


#9

Hi @HardiBarznji there is no major update after 0.0.62, but still there are daily-base updates for some minor stuffs. You can use “Honeybee_Update Honeybee” component to update your honeybee. after it is updated, you can drag the new “Honeybee_Honeybee” to canvas , it will recognize the new THERM.


#10

@MingboPeng 's solution is a good one. Alternatively, you can uninstall Therm 7.6 and use Therm 7.5 instead.


#11

Thanks @chris, I solved the problem using “Honeybee_UpdateHoneybee” component as @MingboPeng suggested.
Thank you guys :slight_smile:


#12

the same question with honeybee 0.0.63 & therm 7.7. According to your suggestion,i uninstall Therm 7.7 and use 7.6,it’s done


#13

@stones ,
You will see in the latest release notes that we are currently only supporting THERM 7.5 and 7.6. You can have THERM 7.6 and 7.7 installed side-by-side and Honeybee should be smart enough to find the version that it is compatible with.

Frankly, I haven’t been able to open the THERM 7.7 interface on my machine yet (I get a weird error):
image
So I think that it may be a while before we have 7.7 support for Honeybee. I have noticed that LBNL is listing 7.7 as a Beta, though, so maybe the hope is that they release a more stable and usable version soon.