Honeybee openstudio 2.8

Hello @chris,

I did have that problem when installing yesterday. I´m not sure what did the trick but (with several tries) I re-installed OpenStudio, Ladybug, Honeybee and the Ironbug 2.8 version. It is working now. I am running windows 10 pro. Please let me know if you need more info.

Best
Arturo

Thanks @LUISARTUROREYESVALEN ,

That is very helpful to know. Let me see if the other person I know experiencing the issue is able to solve it with re-installation.

Looks like I’m in the lucky 10%… I’m getting the same runtime error @chris, running windows 10 pro. I tried re-installing (admittedly only once) OpenStudio 2.8, Ladybug, Honeybee and Ironbug 2.8. But I still got the same runtime error, so I switched back to 2.5.0 for now.

I’d be curious to hear if re-installation works for other folks.

@elmira ,

Sorry for not posting the solution sooner. You can see that the discussion continued here on the OpenStudio GitHub:

https://github.com/NREL/OpenStudio/issues/3529

From what we can tell, you should be able to fix the issue by making sure all OpenStudio versions are uninstalled, then install 2.8, then open Rhino/Grasshopper.

The error I reported just seems to happen when you try to switch OpenStudio versions with restarting Rhino/Grasshopper.

1 Like

I did an OS2.8.0 install today…removed all old versions of OS and started fresh…however I am getting the “1. Solution exception:Unable to find an entry point named ‘CSharp_OpenStudio_WorkspaceObject_SWIGUpcast’ in DLL ‘openstudio_csharp.dll’.” error.

Any further insight on this as I seemed to have followed the “making sure all OpenStudio versions are uninstalled, then install 2.8, then open Rhino/Grasshopper” recommendations. I’ll wait a bit before I go back to OS2.5.0 in case there are any suggestions…thanks!

here is a screenshot of the installed OS dll files…
image

@josh.greenfield ,

Can you check the output of your Honeybee_honeybee component and verify that OpenStudio 2.8 has been loaded (you will see a message there in the Viiiizzzzzzzz!).

Found installation of openstudio-2.8.0.
Found installation of EnergyPlus>9-0-0.
Found installation of Radiance.
Found installation of DAYSIM.
Found installation of THERM 7.6.

Loading RAD default materials…9 RAD materials are loaded

Standard template file is loaded from c:\ladybug\OpenStudio_Standards.json
Loading EP materials, constructions, schedules and material properties from c:\ladybug\OpenStudioMasterTemplate.idf
Loading EP materials, constructions, schedules and material properties from c:\ladybug\userCustomEPLibrary.idf
Loading THERM materials from c:\ladybug\thermMaterial.csv
642 EPConstructions are loaded available in Honeybee library
251 EPMaterials are now loaded in Honeybee library
114 EPWindowMaterial are loaded in Honeybee library
0 EPShadingControl are loaded in Honeybee library
0 EPMaterialProperty are loaded in Honeybee library
1888 schedules are loaded available in Honeybee library
84 schedule type limits are now loaded in Honeybee library
81 THERM materials are now loaded in Honeybee library

Current document units is in Meters
Conversion to Meters will be applied = 1.000
Hooohooho…Flying!!
Vviiiiiiizzz…

Ok, let’s try a few things. First, can you let me know if you are able to run is grasshopper file with your current setup:
test_openstudio_error.gh (523.2 KB)

If not, please post a screenshot of the OpenStudio component’s readMe! output.
Next, if could you try uninstalling OpenStudio 2.8 and install OpenStudio 2.9? As far as I can tell so far, honeybee is fully-compatible with OpenStudio 2.9 so let me know if you are still experiencing the issue in this most recent version.

same error with v2.8.0 and same error with v2.9.1 (see images below).

Hm. Just to be sure, do you have ironbug installed? If so, uninstall it and be sure to delete all of the files within your C:/ drive as shown on @MingboPeng 's installation instructions . I will try to keep thinking of things if you have never installed ironbug on your machine.

Ironbug uninstalled…now I’m getting a different type of runtime error…

no clue what the “C:\Users\Jenkins” is as that is nothing on my-side.

I tried your “Full-Building-Simulation” file from Hydra and that ran with no errors (albeit took 7 minutes to run). So can Ironbug be re-installed now or will that still be an issue?

@josh.greenfield


This is because your rhino file is not in meter.

1 Like

Woohoo! We figured it out!

That error is easy to fix. You just need to make sure that the input geometry is in the same units as your Rhino model units. If you are using the Box in the sample file I sent you, it’s supposed to be in meters as @MingboPeng says.

Ok, now we know that this error was because people had an older version of Ironbug installed and I guess Ironbug was loading the OpenStudio C# bindings before Honeybee had a chance to. If you install the most recent Ironbug, everything should work.

1 Like

Rhino units changed to meters and the test file runs!

I re-installed Ironbug and the test file runs again as well…so is it safe to say that when upgrading to OS2.8.0 and having issues: making sure all OpenStudio versions are uninstalled, Ironbug uninstalled, then install 2.8.0, then open Rhino/Grasshopper and reinstall Ironbug is the recommended path?

@josh.greenfield ,

Following your instructions will definitely work on all machines.

However, I think it is still ok to have both OpenStudio 2.8 and OpenStudio 2.5 installed on your machine if you want to keep them both (as long as both your honeybee and ironbug are up-to-date). I have both versions on my machine right now and they are working well. There’s really not a compelling need to keep 2.5, though, and I really only keep it on my machine to help debug forum issues like this one :slight_smile:

BTW, I am pretty sure that the most recent Honeybee is fully-compatible with OpenStudio 2.9 (it has worked well in all of my tests thus far). So upgrading to 2.9 should also be an option now.

thanks Chris…I really appreciate the help to get this fixed! as I’m running ONLY OS2.9.1 right now, I’ll let you know if I have any issues that I didn’t have on OS2.5.0…I’ve already ran a complex energy model (with Ironbug) and a thermal comfort analysis (with every comfort recipe left and right) and no issues so far!

Right, Ironbug will load OpenStudio dll when starting the GH in rhino. Ironbug also always loads the most updated version of OpenStudio installed in C drive, unless you want a specific version to be loaded by copying openstudio dll files to c:/Ironbug folder.

This might be the reason that causing the OpenStudio conflicts, @josh.greenfield have copied an old version of OpenStudio dll files to ironbug folder, and “uninstalling” (removing the Ironbug folder) fixed it.

@chris I think I remember there was an issue that Honeybee_honeybee finds the most updated OpenStudio dlls when two versions like 2.8.0 and 2.8.1 are installed. Honeybee_honeybee will load 2.8.0 instead of 2.8.1.

so I think I “might” know what happened…I’ve had Ironbug installed since the Beta release (August 2018)…at that time, the Ironbug installer copied over the openstudio_csharp.dll file into the C:\Ironbug folder (along with a few other OS dll files)…updated Ironbug version installs since then don’t do that anymore (right @MingboPeng?) BUT for every update I kept extracting the new Ironbug zip into the folder and overwriting old files, but never cleared out Ironbug files that weren’t “needed” anymore…thus the csharp.dll file remained in the Ironbug folder since the Beta release and didn’t cause any issues until my recent OS upgrade today.

image

Right, exactly! Sorry, I should have been more clear for upgrading from the beta version.

Thank you @MingboPeng and @josh.greenfield for clarifying. It’s also good to know that we’re no longer distributing the OpenStudio.dll with Ironbug since this should stop any issues like this from popping up in the future.

I was able to recreate the issue you mentioned, @MingboPeng, where it was not distinguishing between OpenStudio version 2.x.0 and 2.x.1. I just pushed a fix and it should all work correctly now: