HoneyBee v.0065 cant find OpenStudio 3.1.0 :((

Hi Friends,

I’ve read and followed the instructions of the other threads on this topic but I still can’t get honeybee to work :confused: I’ve also added the extra honeybee resource files and unblocked the files too. And i’ve tried disabling/enabling the node too. Nothing has worked

Any help is DEEPLY appreciated!!

Attached are some screenshots of what I’m seeing!


Not sure if the image from the initial post can be seen. Hope this one works

Your version of Ladybug Tools is not compatible with OpenStudio 3.1. You are not using the latest Legacy plugins (LB 0.0.69 and HB 0.0.66 - see https://www.food4rhino.com/app/ladybug-tools), which is necessary if you want to use the Legacy versions next to the new LBT versions.

See this thread for further information (which links to others):

Also check the compatibility matrix to see which version is compatible with what:

What threads are you referring to?

Thank you for your reply! I really appreciate this!

I downloaded the Open Studio 3.0.1 and reinstalled everything and still I have the exact same error messages.

I was following this thread


Well, I’m not sure what you are doing or trying to do.

Please refer to Chris here:

Also note that latest honeybee legacy will continue to work out of the box with OpenStudio 2.9.1 so we might recommend using that unless there’s specific feature in OpenStudio 3.0 that you would like to make use of.

So if you are using Legacy you should stay with an older version of OpenStudio (2.9.1), or use the latest LBT 1.x version to have access to 3.0.1, if you need 3.1, then right now you need to use the development version.

Given that you are fairly new to the forum (I don’t know your experience with LBT or energy modelling), I recommend you stick to the “base” installations to get familiar with the ecosystem and not trying to match the Legacy plugins with the latest and greatest OpenStudio, but I might be wrong here.:slight_smile:

In short:
LB 0.0.69 and HB 0.0.66 -> OpenStudio 2.9.1 (this is what you were trying to get started with)
LBT 1.1 -> OpenStudio 3.0.1
LBT [development version] -> OpenStudio 3.1

You also have problems with Therm, don’t install the latest 7.7, it won’t work (7.6 is the one you should use). But you also have problems with Radiance and Daysim too, so either you have permission issues (did you unblock the components before installing?), or something else, I’m out of ideas here.

1 Like

@rismail88 ,

For the legacy plugins, you have to install OpenStudio in it’s default location in the root of C:\ drive. The openstudio in the ladybug_tools folder is only for the LBT plugin.

Everything that @furtonb said about the version of OpenStudio to be used with the legacy plugin is also correct.

1 Like