How to get Honeybee Legacy working with OpenStudio 3.0

Hello all,

I just wanted to announce that we have gotten the latest version of Honeybee legacy (July 06, 2020) to work with OpenStudio 3.0 but, because NREL released OpenStudio 3.0.0 and 3.0.1 with a small error in their C# bindings, there’s one extra step that you will need to do if you want to use honeybee with OpenStudio 3.0. Otherwise, you will get the infamous PINVOKE error like so:

Specifically, you need to go into your lib folder within the OpenStudio 3.0 installation and copy the two files that you see here:

Then, you need to paste them into the CSharp/openstudio folder like so:

Then, make sure that you are using the latest Honeybee_Export to OpenStudio component (July 6th, 2020 or later) and your simulation should run.

For people are viewing this issue a few months from now, there is a good change that NREL has fixed this issue in their latest OpenStudio release so there’s hopefully be no need for the workaround above. Also note that latest honeybee legacy will continue to work out of the box with OpenStudio 2.9.1 so we might recommend using that unless there’s specific feature in OpenStudio 3.0 that you would like to make use of.


Hi Chris and ladybug team, I installed the latest version of ladybug and honeybee, and I still getting this error: 1. The simulation has not run correctly because of this severe error:
2.* Severe ** [ShadowCalculation][ShadowCalculation 1][shading_calculation_method] - “AverageOverDaysInFrequency” - Failed to match against any enum values.
3. The simulation has not run correctly because of this severe error:
4.* Severe ** [ShadowCalculation][ShadowCalculation 1][shading_calculation_update_frequency_method] - “30” - Failed to match against any enum values.
5. The simulation has failed because of this fatal error:
6.* Fatal ** Errors occurred on processing input file. Preceding condition(s) cause termination.

Someone told me this was due to and overhaul caused by the Energyplus version, is there anyway to fix it?

1 Like

@Dconforte ,
Are you sure that the OpenStudio component you are using is from JUL_07_2020 ? The only way that I would expect that error is if you are still using the old OpenStudio component with OpenStudio 3.0.

@chris yes! I downloaded the latest release from honeybee, and I’m still getting this error, I downloaded the one from July_06_2020
Or I just have to download only the component you mentioned in order to run the simulation? I followed suit to your tutorial on youtube. I have Energyplus 9.3.0 and Openstudio 3.0.1 installed

I hope you don’t mind that I moved your post to the topic that is specific to OpenStudio 3.0 integration. Can you confirm that “Honeybee_Honeybee” says it has loaded OpenStudio 3.0.1 ?

@chris no problem, sorry to bother on this post though, and yes, I confirm that Honeybee_Honeybee loaded OpenStudio 3.0.1.
One thing that it’s strange to me is that it says it loaded Energyplus 9.0.0 although I got the 9.3.0 version installed
Also, thanks so much for the attention!

Ah, therein lies the issue! I am definitely getting a clear EnergyPlus >= 9.3.0 on my end:

So it seems that your machine is using the new OpenStudio to write the IDF file but using an old EnergyPlus to execute the simulation. Can you confirm that you are using Honeybee_Honeybee from JUL_07_2020? And, if so, can you send a screenshot of what your C:/ drive looks like along with what’s inside the C:\openstudio-3.0.1 folder?

I downloaded the honeybee file from JUL_06_2020, was there some update on the files between days? I’ll download the file from JUL_07_2020 and see how it goes.

Here’s what is inside my C:/ and inside C:\openstudio-3.0.1 folder

I downloaded again the file from JUL_07_2020 and still getting this error report, what is the workaround I can do to make Honeybee recognize the Energyplus 9.3.0 instead of 9.0.0?

I’m sorry @Dconforte . I’m having a hard time recreating the issue on my end. Does “honeybee_honeybee” still say that the EnergyPlus version is >= 9.0.0 even after you are using the JUL_07_2020 version?

If you can open the attached .gh file on your machine and send me a screenshot of the outcome, that will help me debug. (92.8 KB)

Now I get it, I was using an older version of the Honeybee_Honeybee, but still, when I ran the simulation, I still get some errors, now Honeybee is recognizing the new version of Energyplus, but still some errors ocurred.
Here’s the file I’m using attached.
Once again, thank you so much for helping me @chris, wish you all the best

It looks like you accidentally broke the link to your attachment but I can see a component from JAN_01_2020 in your screenshot and I would make a wager that the error is linked to that.

Remember that you can use the “Ladybug_Update File” component to automatically sync your Grasshopper definition with whatever version of the plugins you have installed.

If this doesn’t fix things, upload your file and I’ll see if it recreates the error on my end.

Everything now works just fine, thank you so much for the support, wish you all the best Chris!

1 Like

Hi Chris,

I have downloaded the newest version of openstudio 3.0.1 and did exactly what you said. im still getting en error message: “1. Solution exception:Unable to find an entry point named ‘CSharp_OpenStudio_toPath’ in DLL ‘openstudio_csharp.dll’.”

I do not really know coding and could not figure out what does it mean. Could you please give some advise?

Hi @lml, this is because your Ladybug/Honeybee version is too old to work with newest openstudio. Please update the Ladybug/Honeybee and update the old components in you GH files.

Hello, I have downloaded the version of openstudio 3.0.1, and I have done what has been indicated above. I have changed all the components of the Honeybee to the latest ones.
However, I have still got an warning sign, as the image shows. Could this problem be solved?
Thank you.

Thank you Mingbo! Problem solved.

That’s not an issue with your version of OpenStudio, @Syo . It seems related to your geometry. I suggest opening up a separate topic and provide a sample with the minimum geometry needed to recreate the error.

i too installed this but different version showing in output.


Edit: Solved it. Thanks all