How to Manually Add Ladybug Tools to the Rhino Python Path

Radiation Rose is not yet in the LBT plugin. It should hopefully be there in the next stable release.

1 Like

Thanks for clarification, anyway I downloaded the legacy version.
Keep the great work

Thank you for your workaround, however I do not agree with:

I find that hard to believe. APPDATA is like a default environment variable in Windows. If I enter %APPDATA% in the address bar of Windows Explorer, it goes to C:\Users[USERNAME]\AppData\Roaming
If I type echo %APPDATA% in the command prompt it returns C:\Users[USERNAME]\AppData\Roaming

I tried to install the new Ladybug Tools 1.1.0 on two laptops and one desktop computer and all failed. I think something is wrong in the installer.

Hum, installer worked fine for me after I got admin rights to my computer. It was impossible to install before and what Chris showed seems to be exactly the workaround. What is the issue you are getting into when installing?

Great guy @chris
seems to work now. can’t wait to experimenting with the latest LBT version.

A post was split to a new topic: Rhino crashing when dropping honeybee components on the canvas

Thank you @chris, that fixed the issue for me.

In all my cases, having admin rights on my personal laptops and desktop, I first had to add C:\Users\[USERNAME]\ladybug_tools\python\Lib\site-packages in Rhino Python options to get set_python_path.bat running properly and to get Ladybug Tools components working in Grasshopper.
In my cases Ladybug Tools is not automatically added to the Rhino Python Path. I had to add it manually.

FYI, I think we have identified why so many people have had to manually specify the python path. It seems that Rhino doesn’t create the settings file that the installer tries to edit if someone has never dropped a GHPython component on their Grasshopper canvas before.

We have added some code into the development version of the LBT plugin that creates this settings file if it does not exist. So, when we release LBT Grasshopper 1.2.0, people should not have to use this manual workaround anymore.

1 Like

This thread helped out lot, finally got Ladybug running! Now its doing this thing where it keep trying to update to new components. I’ve deleted the dot_net folder and it wanted to restart Rhino/Grasshopper again after that and it’s still showing up like this. Do I ignore it now or is something wrong?

Hi Chris, thanks a lot for the information.
For some reason, there are still warnings/errors when installing the LBT, any idea?

Thanks a lot, Chris.

Regards,
Chris

Yes, @IvanD ,
You can just ignore it. We haven’t updated the .gha file since the first time we created it so you are not missing out on anything. But, when we eventually update the component, you would have to delete the dot net folder, restart Rhino/GH and re-run the versioner to get the new file. This is just the only way to update the .gha files given how they work in Grasshopper. But we’ll put a note in release notes if we ever update the dot net package.

@gqia002 ,

It looks like a firewall is blocking the installation of packages from PyPI (the Python Package manager). I would either get your IT to add an exception for PyPI or just have your IT buy a single-click installer from us, which will probably save everyone a load of time.

Hi @chris , thanks for this. Unfortunately after following all these steps, I am still having an issue installing Ladybug on my computer. Any idea what could still be holding it back?? Thanks

And to add, I attempted to follow these instructions,( Failed to import xxx: no module named xxxx LBT 1.0.0 release - #11 by chris ) but Ladybug will still not run, as per the screenshot below. Appreciate your help!! Thanks :slight_smile:

Hi @arielres,

Can you replace a folder named ‘ladybug’ at C:\Users\Admin\ladybug_tools\python\Lib\site-packages with the following zip (extracted)?

It would be good to keep rhino+gh closed while doing this. If it’s open, make sure to restart rhino+gh once this is done.

ladybug.zip (209.6 KB)

Thanks @devang . I somehow didn’t even have a ‘ladybug’ folder there, so I have now added yours. Unfortunately I am now getting a slightly different error message. (Rhino and gh were both closed at the time). Any advice now? Thanks

This clearly shows that your installation is not complete.
You should extract and place this (46.3 KB) folder at the location I mentioned in the message above.

1 Like

Thank you! Now It works fine on my Rhino7!

Thanks Dev. I have replaced the folder like you suggested and re-installed ladybug via the grasshopper installer, but am still getting an error message. Any suggestions on what might still be going wrong? (Is there any meaning to the “pip install”?)

Thanks

Hi @arielres ,

It looks like second component of the Food4Rhino installer failed to install all of the python packages via the Python Package Manager (PyPI or pip). You could try just running the second component of the installer again since it seems that maybe your internet connection just dropped out while you were in the middle of running it the first time. If that doesn’t fix it, most likely, there’s some sort of firewall that has prevented you from installing things via pip on your machine.