I can't install Ladybug in Rhino7

I just started Rhino and Ladybug recently
I’m having trouble with installing Ladybug in Rhino 7.

My problem is kinda different with others.
I opened ladybug installer and installed it successfully. Step 1 and step 2 have passed successfully.

The problem occurred when I’m trying to open “set_python_path” file.
“This app can’t run on your PC” error occurred.

Yes, so I tried to fix “This app can’t run on your PC” error by searching internet and tried everything but it doesn’t work.
And also, I tried How to Manually Add Ladybug Tools to the Rhino Python Path this post already. And I think the post is for the people who can’t have “set_python_path” file but I have that file. I just can’t run it. Anyway it didn’t work as well.
Plus, I’ve already uninstalled and reinstalled Rhino and Ladybug lots of time.

Literally I tried everything to fix it but it doesn’t work. What should I do?
Should I format my windows?

I believe you don’t have to do that extra step in Rhino 7. We use Rhino SDK functionality which was added to Rhino 7 for this purpose. It is, however, is not available in Rhino 6.

Thanks for answering.

But I’ve recognized that already. So I intentionally didn’t do the step, but it doesn’t work as well :frowning:

Any idea?

What is it that “doesn’t work as well” ? Are the components not working?