Importing IDF to Honeybee


#1

Dear @mostapha

I want to import an idf file into honeybee, but the component is not importing the whole settings and only imports the geometry as it is said…

How I can solve this problem ?

I attached the idf file that I want to be imported … Btw I have installed EnergyPlus 8.8.0 …

Thanks in Advance

Case600.idf (33.4 KB)


#2

Hi @AMIRTABADKANI, What else do you want to import? I have been thinking to switch to OpenStudio and user their method to import idf files but even that doesn’t import all of the information.


#3

Dear AMIRTABADKANI

See image:

other way: import idf from plugin openstudio (Sketchup) and save to osm file.
My computer use Energyplus ver 8.3 and 8.6.


#4

Hi @mostapha

Sorry for my late reply
it even does not import the glazing parts of the geometry ,
َAlthough it would be really helpful if we can import the whole information like constructions or HVAC properties of an idf file into HB as far as it is running through E+…
Otherwise importing only the geometry doesnt help much if we want to link between interfaces in a project …


#5

Hi Thanks for your reply

If you check the result it is only a solid box without even glazing parts that supposed to have in E+…


#6

There are two error messages in the bottom that it failed to import fenestration surface. The component does import constructions and schedules from the idf file as @NguyenHoang582 pointed out.


#7

See this file: import_idf_zone_name_with_space.gh (97.3 KB)

The issue was the zone name which has a white space. It makes honeybee confused. I added a catch for that. It’s true that EnergyPlus accepts names with white spaces but since Honeybee has to handle other programs including Radiance it’s always a good idea to avoid white space in names.


#8

Glad that the white-space issue was solved and I wanted to add that there isn’t an interface in existence that will import detailed HVAC systems from an IDF. Enabling something like this would be a multi-year effort for a software development team and our best hope of seeing this is if OpenStudio team does it and we can then use their SDK to enable it in Honeybee. For the time being, we will try to support everything aside from HVAC, including all geometry, schedules, loads, and constructions.


#9

Dear Mostapha,

I’m having issues with importing idf to honeybee. I have used the files uploaded here and I’m getting a message that “A very tiny glazing is removed from ZONE_SURFACE_SOUTH” and the glazing is not shown. These files work perfectly in other computers and I tried reinstalling rhino as well as LB_HB. Do know you why this is happening? Any help is much appreciated.

Thank you.


#10

Apologies. It had to do with the Energyplus versions. I was using the latest Version E+V9. The glazing was displayed when I installed a previous version 8.8.

Regards
Renjith


#11

I’m currently getting this error with E+V8.9. I also tried installing 8.8, and got the same error. Any thoughts?

Honeybee 0.0.64 / Ladybug 0.0.67
Current Rhino Version (6.10.18311.20531)

Edit: I was able to get around the error by changing Rhino units to meters and recomputing everything. Is there any way I can work in inches/feet and still get this to work? I know, imperial units are stupid, but it’s all my little brain can handle.


#12

@Steven

Changing the units to meters should fix this for most people and I have a hunch that it was probably the case in @Renjith 's model as well (the import IDF component works completely independently of installed E+ version so it does not make sense that the version of E+ fixed the issue). IDF files are always in meters so the Rhino model units should be meters when they are imported.


#13

Hi Chris,
Use of different units in Rhino just scales up or down the model depending on the units specified.
In E+ Version 9, number of parameters used to define the fenestration surface is less (maybe more… don’t remember correctly now) than that required in previous versions. So import idf component misreads the coordinates. This was cause of error in my case.


#14

Makes sense, thanks!