Incident Radiation using Mesh Geometry (Error)

Hey All,

I am doing simple radiation analysis with the LB Incident Radiation component (1.1.0). The component works fine when I use BREP input geometry but shows 0 incident radiation when I use mesh input geometry.

Also tried manually offsetting the mesh, but the results for that don’t look right:

Using the same mesh input geometry works fine with the legacy version:

Looking through the code inside the LB Incident Radiation component, my hunch is that the component is not offsetting the mesh for the study_mesh and thereby using the same mesh both as the study_mesh and shade_mesh (self-shading), which is why the entire geometry is shading itself and not getting any radiation. I thought offsetting the mesh manually would fix it, but in that scenario, it seems like the offset mesh is being used both for study_mesh and for self-shading.

Please let me know what you think - if this is a bug or if I am missing something. I have attached the Rhino and Grasshopper files for reference.IncidentRadiation MeshvsBrep Input.3dm (94.6 KB) IncidentRadiation MeshvsBrep (460.9 KB)

Also, wanted to know if the contextTransmit_ feature that allows the user to set transmittance values for context geometry is a part of LB 1.1.0 / if it would be possible to include that? I find it a very useful feature especially for modeling deciduous trees during different seasons and it would be great to have it in the new Ladybug! #wishlist

1 Like

Your hunch is not wrong. The offset distance is not being applied when you supply a mesh. We will look into this. Thanks!

Good catch, @eeshakhanna
In fact, your hunch was completely correct. I just pushed a fix, which you should be able to get with the “LB Versioner” in a few minutes:

And thanks, @devang , for identifying it as a bug.

1 Like

Hi Guys,

same bug seems to be in the Incident Radiation component.



Having this same issue and when i went to use the LB Versioner component i received the following error

  1. Solution exception: Download failed with the error:
    The remote server returned an error: (404) Not Found.

Please assist,


@cflynn29 there is no such version of LBT (1.26.1), if you hover your mouse over the version_ input of your component, it gives you the correct link for LBT releases (you were looking at ladybug-grasshopper releases, not lbt-grasshopper). You can double click the component to open it, or right click and choose “Open Editor” to get access to the Python code and copy-paste the URL from there in your browser to check each release.

The fix that you were looking for was released in LBT version 1.1.4 according to the release notes:

Removing the version string updates you to the latest development version, which is 1.1.22, quite a bit fresher, released just before Christmas.

Hope this helps.

1 Like

That helped immensely, i was able to update everything and that issues has been solved.