Installation errors with OpenStudio App and also with installing version 1.8 of LadyBug Tools on Apple Mac M3 chip computers

Kia ora @chris and @mostapha and anyone else listening.

I have encountered a very curious feature with installation of Mac versions of LBT.

I have a class of 330+ first year students due to front up to a tutorial in two batches of 160+ on Monday at 8:30am, and I have encountered a weird issue with the check versions component. (it is Friday evening now)

Check_Versions.gh (7.5 KB)

I have asked them to install the software (which should have been done in a course in the first trimester, but not all students followed those instructions. They are then to run this attached “check versions” script.

Oddly, I encountered the component error but for a very weird reason:

As can be seen, the check versions component reports it is from an old version of python but notes the error is because the open studio application has not been installed properly.

At first I thought this was a problem that students had been installing the INTEL Open Studio instead of the ARM version. But, apparently not.

What has solved the issue on a colleague’s and on a student’s Mac is to install the OpenStudio program, instead of the Open Studio App.

Just installing Open Studio 3.7 and restarting Rhino produced the following output from the Check Versions .gh file I had distributed.

I am revising the pre-tutorial instructions to recognise this issue. However, I am wondering is there any other explanation?

1 Like

Kia ora

I am adding a question here

This error message on a student’s “brand new” Apple computer, seems to indicate an error with the grasshopper installer from Food4Rhino and the CPU. Odd?

There seems to be a link to this entry Mac Installation but I cannot think of why there should be an “executable error” with the grasshopper files?.

The computer uses the new M3 chip. “Bad CPU type in Executable” when the executable is the Python script interpreter is an issue I am struggling to figure out.

I will suggest in the meantime that the student follow the remove all approach at the end of that thread …

Hi @MichaelDonn,

I’m no Mac user and I can’t provide any suggestions here but @chris or some other users on the forum might know what might be happening.

I don’t really know what is happening either to cause the “Bad CPU” error. This is the type of thing where Google is going to be more helpful than anything I can say. It looks like this person solved it for themselves here:

https://discussions.apple.com/thread/250777998?sortBy=best

And, yea, Ladybug Tools uses OpenStudio SDK not the OpenStudio Application. The two are different installers that install different pieces of software so it’s not going to work if you install the OpenStudio Application in the ladybug_tools folder.

Kia ora folks

The student and a colleague report that the solution that worked for them to the M3 execution error was the following:

Hi Michael,
Yes! I found the Rhino file and successfully ran the daylight/shoe box file.
Yiwen and I found that on the new MacBook laptops, we had to first install Radiance and OpenStudio BEFORE installing Ladybug [this is different to the installing video which installs Ladybug first]. After installing these two applications, force quite Rhino and install Ladybug tools [if LadyBug is already installed like mine was, we just needed to delete the Python folder and Python zip file and then click the 2nd toggle to true]. This should then successfully install the Ladybug tools after force quitting and reopening Rhino.


Hopefully this has made sense!
Thanks,
H…


This solution makes no sense to me - especially deleting the Python file.

Any thoughts?