Invalid integer Literal error line 3639, line 1689, line 2404

  1. I have installed the latest version of Open Studio 2.7.0, the latest version of Energy Plus 9.0.1-bb7ca4f0da and I have updated the ladybug and honeybee both as well. Still I am getting the same errors.
  2. After connecting the Honeybee_GlazingBasedOnRation component, some more errors are coming.

    I am attaching the latest files. Please check.
    Thank you.3D model.3dm (251.9 KB)
    My (556.2 KB)

Use the exportToOpenStudio component instead of the runEnergySimulation. It runs fine.
Seems to be that the later is writing wrong different fields in the IDF. Right now i can’t check and show that but @chris should be aware of this (probably) bug.

In my case EnergyPlus 8.5 and OpenStudio 2.1 it runs without any severe errors

OK. So probably the issue is related to EnergyPlus9 and/or OS 2.7, which i also have installed. The exportToOpenStudio will do the job fine.

Hi @AbrahamYezioro
I have tried ExportToOpenStudio component also instead of RunEnergy Simulation component. But in my case, this is also not working.
3D model.3dm (251.9 KB)
My (612.9 KB)

Can you try a different EPW. I’m starting to suspect the one you are trying to use is faulty.
When i checked it worked well.

  1. I have changed the EPW file and my model is working well now with the exportToOpenStudio component. Thanks @AbrahamYezioro
    But it’s not working with RunEnergySimulation component.
  2. I am having a set of EPW files and those files are not working actually…can you tell me that what can be the possible solution for this. I am attaching the source of EPW files for your reference.

Good.It confirms that the runEnergySimulation is not updated to the last E+/OS. Anyway, the intention is to fade it away in time … as i understood. @chris can respond on those 2 more in detail.

As for the onebuilding source i can’t help much. Again @chris and @mostapha are the address to this issue. In any case you can look at those both links: 1 and 2, for some info.

1 Like

Thank you @AbrahamYezioro

@tarun0949 ,

Yes, there were a lot of updates to OpenStudio and Energyplus in their latest releases. I’ll work now on seeing if I can bring the Run Energy Simulation up to date with the current E+ version. For now, your options are either to use the OpenStudio component as @AbrahamYezioro says. Alternatively, you can just use an older installation of OpenStudio (like Version 2.4 or 2.5). Both of those versions work well with the current components.

Also, if you don’t find the solution to the issue with onebuilding EPWs, feel free to open another discussion.

1 Like

@tarun0949 ,
I updated the “Run Simulation” component so that it can now work with E+ version that are greater than 9.0:

Here’s a file showing that it now works with this version: (547.5 KB)

Hello all…
First of all, Thank you @chris for updating the Honeybee_RunEnergySimulation component. Now, this component is working fine and the errors which I was getting previously has sorted out.

Here I want to drag your focus on one more thing that-------
****When I am applying glazing on my honeybee zones by using Honeybee_GlazingBasedOnRatio component, it’s giving me warnings. I don’t know again that this is an update issue or something else :thinking:. I have tried using both Honeybee_RunEnergySimulation and Honeybee_ExportToOpenStudio components but in both the cases glazing surfaces are missing in the final IDF file.

Case 1: By using Honeybee_ExportToOpenStudio component
Glazing surfaces are missing in the final IDF file and Honeybee_ExportToOpenStudio component not even giving any warnings about this.

Case 2: By using Honeybee_RunEnergySimulation component
Glazing surfaces are missing in the final IDF file and Honeybee_ExportToOpenStudio component is giving warning i.e. “Failed to build fen srf

I am attaching my files and screenshots for your reference.
3D model.3dm (252.0 KB)
My (630.5 KB)

Thank you.
Tarun Verma

1 Like

Hello @tarun0949 !

I have the same problem that you had with the missing glazed surfaces in the idf-file. Did you find any solution fro that problem?

Thank you

I just started the whole process again.

Did you just start the process of trying to solve the problem or did you rebuild your project and solved the problem that way?


I rebuild my project from the scratch…As per my knowledge…I was facing that problem because of compatibility issues in open studio, energy plus and honeybee.

Okej, then I try to update EP, OS and HB. Are you running the latest updates?

Yea…I am using the latest versions…but for full compatibility you can use open studio 2.5 instead of 2.7

I’m facing the same issue. I don’t understand how creating from scratch would help, since I will be doing everything pretty much the same. Also, I couldn’t find any links to download legacy versions of Open Studio. :confused:

i was having this problem, so i downgrade the open studio 2,7 to 2,5 and the windows come back :smiley: old ones