Invalid integer Literal error line 3639, line 1689, line 2404

Hi…I am doing energy simulation for a very basic model and while running the simulation I am getting an error in Honeybee_run energy simulation component.

If you could share the file It would help us help you quicker.

My (608.4 KB)
3D model.3dm (251.9 KB)
Please find the attached files.
Thank you.

Please connect simulationOutputs from the Honeybee_Generate Ep Output component to the simulationOutputs_ on the Honeybee_run energy simulation component.

Hi…I connected the simulation outputs from the Honeybee_Generate Ep Output component to the simulationOutputs_ on the Honeybee_run energy simulation component. After that, I simulated and got these errors.

Please check the following discussion. Hope it helps

You should also read these guidelines please.

Thanks for replying immediately.
I tried and rectified some errors but still, I am getting some errors.
Anything on these errors?

Can you share the latest file?

3D model.3dm (251.9 KB)
My (547.6 KB)
This is the latest file. Please Check.

Your file is working as is at my end.

If you are using the latest version of OpenStudio then you need to also use the latest version of Honeybee. There has been a change in EnergyPlus RunPeriod object and that’s why it gives you an error.

@chris, I thought the fix in this case is backwards compatible but it seems there are cases like this that can fail.

  1. I have installed the latest version of Open Studio 2.7.0, the latest version of Energy Plus 9.0.1-bb7ca4f0da and I have updated the ladybug and honeybee both as well. Still I am getting the same errors.
  2. After connecting the Honeybee_GlazingBasedOnRation component, some more errors are coming.

    I am attaching the latest files. Please check.
    Thank you.3D model.3dm (251.9 KB)
    My (556.2 KB)

Use the exportToOpenStudio component instead of the runEnergySimulation. It runs fine.
Seems to be that the later is writing wrong different fields in the IDF. Right now i can’t check and show that but @chris should be aware of this (probably) bug.

In my case EnergyPlus 8.5 and OpenStudio 2.1 it runs without any severe errors

OK. So probably the issue is related to EnergyPlus9 and/or OS 2.7, which i also have installed. The exportToOpenStudio will do the job fine.

Hi @AbrahamYezioro
I have tried ExportToOpenStudio component also instead of RunEnergy Simulation component. But in my case, this is also not working.
3D model.3dm (251.9 KB)
My (612.9 KB)

Can you try a different EPW. I’m starting to suspect the one you are trying to use is faulty.
When i checked it worked well.

  1. I have changed the EPW file and my model is working well now with the exportToOpenStudio component. Thanks @AbrahamYezioro
    But it’s not working with RunEnergySimulation component.
  2. I am having a set of EPW files and those files are not working actually…can you tell me that what can be the possible solution for this. I am attaching the source of EPW files for your reference.

Good.It confirms that the runEnergySimulation is not updated to the last E+/OS. Anyway, the intention is to fade it away in time … as i understood. @chris can respond on those 2 more in detail.

As for the onebuilding source i can’t help much. Again @chris and @mostapha are the address to this issue. In any case you can look at those both links: 1 and 2, for some info.

1 Like