LB_Terrain Generator

I’m trying to create a terrain using a the LB Terrain generator. However, When i run it, I have no output. Could someone tell me where i’m going wrong?

The _runit toggle seems to be set on False. I imagine you’ve checked bu just in case have you tried setting it to True and then show us the error message you are getting from the readMe!?

1 Like

The toggle is not the problem here. I don’t get an error message. The panel connected to the result shows that there is no output (null).

It actually is! Set it to True.

The output is still ‘null’.

cc: @AntonelloDiNunzio

Hi @zahabia,

this version of component does not work anymore.
You need to provide an API key to use Google API.
Could you test the new one and please make sure you have enabled correctly a Google Project and an elevation API service too.
Make sure that you do not receive a message like this:
Connect a panel to new version of component see response from service.

Otherwise, you can use JawgMaps. It is easy to set.


1 Like

Hi Antonello,
I’m trying to use Terrain Generator using JawgMaps and I always get error " 1. Please check your internet connection. 2. Please try again, you lost some data." I’m connected to the internet and there is no issue with that.

I could not figure out exactly what I’m missing. Any idea how I solve it. Thank you

terrain generator_alshayeb - (393.5 KB)

Hi @MohammedAlshayeb,

If you read response you can see HTTP Error 429: Too Many Requests.
A way to manage it is using “sleepFactor” input:

Component manages only elevation data for JawgMaps data. If you use GoogleAPI and MapQuestAPI you can manage also textures.


Thanks @AntonelloDiNunzio,

Can I get the image with JawgMaps? I got the elevation data but there is not image.