No errors but also no vectors


#21

Hi Viola,

I don’t think you were actually meshing, or at least in the file there was only true for write and not run in SHM component. I have adjusted the definition a bit, adding a small native GH of finding logical values for your wind tunnel based on your geometry, adding castellated and snap in the SHM options (it might be ok to not snap here but we almost always need to snap in production), and have added a small offset to your monitoring surfaces to ensure you don’t get values outside of the mesh.

I don’t see a reason this won’t run end-to-end successfully. If it does not, please post here the logs for blockMesh, SHM, and solution, which you can find in the logs folder of the case.

180702_01_0_outdoor_airflow_VM2_TG.gh (518.9 KB)

Kind regards,
Theodore.


#22

Hi Theodore,
many thanks for the help you are giving me.

I ran what you sent me and this is what I got:

Is it what appears to you too please?

It doesn’t look right to me, e.g. no turbolence behing the building, and instead just straight vectors…?
Also, it’s vertical, how can I have the horizontal view please? I still don’t dominate the tool, sorry…

I basically aim to get a similar image as Mostapha’s video:

And the original example file you guys provide is (I think it’s the previous BF and OF version though):
01_0_outdoor_airflow.gh (427.1 KB)

Finally all the logs you asked for:
blockMesh.log (2.5 KB)
decomposePar.log (4.2 KB)
reconstructPar.log (2.8 KB)
reconstructParMesh.log (3.3 KB)
simpleFoam.log (599.9 KB)

There is also a “rm.log” which is 0kB and therefore I can’t upload it here.

Please just let me know if you need anything else.

One question, is it normal that I don’t see the folder “1” which instead seems to appear to Mostapha after he runs the SnappyHex mesh in his Outdoor airflow video?

Thank you.
Viola


#23

Hi Theodore,
please do you know I could solve this above…?

I tried to look at it horizontally but it’s still showing only straight vectors to me, not sure if I m doing right though…

Many thanks, V.


#24

Hi there,
just to update this topic,

The error could be solve this way: simply set casteleted mesh option (set it to true or false don’t remember). Don’t know exactly why this happend but, It should work properly.


Am I right @viola.maffessanti ?

Best
-Charles C.


#25

True, this remained open, Charles, thank you.
My understanding of the reason why is that Castellated Mesh should be set on True to allow the Snappy refining the mesh. So either you disconnect the wire from the Toggle as you suggested, as by default it’s True, or in the file Thoedore sent me I think it was just a matter of setting the toggle to True, depends on whether you want to snap or not. Which is pretty much what Theodoros wrote in his answer 21. If I am not wrong, of course.


#26

This document goes through each step of the meshing using SnappyHexMesh. I strongly recommend it to anyone who wants to use Butterfly and SnappyHexMesh.