No errors but also no vectors


#1

Hi all,

after few issues now solved, I could finally run all the steps and none gives me error anymore, but when I run the solution I can’t see any vectors appearing, nor at the end of the run.

Could anyone help me out with this please? Here attached also my file.
Many thanks.

Best,
VM

OpenFOAM 1712 // VM 5.2.12

01_0_outdoor_airflow-VM.gh (866.0 KB)


#2

Works file at my end. Can you please show picture of your Rhino? Rhino units in meters?


#3

Hi Devang,
you are right, I set the Rhino file to meters and I can now visualise the vectors, thanks a lot.

However, the solution only runs 32 iterations (instead of the set 600) and the vectors are all straight, it looks like the buildings are not being considered.
Also the solution pops out suddenly in one go when I run Write, vectors don’t appear gradually as on Mostapha’s video.
Also folder 1 has not been created, see pictures. Otherwise, no errors to any of the components, so I am not sure why this is not working… any idea please?
Thank you very much, Viola

No%20-1-%20folder


#4

I will delete the case folder and restart everything. Rhino , GH, OpenFOAM.


#5

Ouch, this is a big thing then.
It can’t be just due to OpenFoam, as I’m using the 1712 version perhaps? E.g. Compatibility with BF and VM?
Or what I have is ok and it’s a major issue which requires pretty much reinstalling everything?
Just as I’m not having any other issue with anything else otherwise… thank you… Viola


#6

Hi Devang,
if I have to reinstall all, would Butterfly work well on Rhino 6 too or only on Rhino 5?

Also, currently I have these installed:
Rhino: 5 SR5 (5.5.30717.16015, 07/17/2013)
Grasshopper: 0.9.0076 (August 27, 2014)
Butterfly: 004, updated as per your suggestion on: https://github.com/ladybug-tools/butterfly/issues/341
OpenFOAM 1712
VM 5.2.12

Are these all compatible with each other please and can I re-install these same ones?

Thank you. Viola


#7

Hi Viola,

I think Devang was only suggesting you delete the folder of your case in /butterfly and then restart your rhino/gh to start over.

There’s no real need to update OF or anything else I think.

Kind regards,
Theodore.


#8

Oh, thank you, this sounds much better…
The purge component in the example file doesn’t work to me, how am I supposed to delete the folder of my case in BF please?
Thank you. Viola


#9

You can access all BF folders for all your cases at your C:\Users\username-here\butterfly folder


#10

Hi Theodore,
I tried to follow your suggestions several times but it is still not working, and the folder “1” is not created.
Sometimes it’s going on without errors, but still the vectors look like my picture I sent few messages ago, like if buildings were not there, but lately it’s giving me the error as per picture here attached.
Anything else I can do to make it work please?
Actually an error appears in the OpenFoam_start which I also attach here below.
Thank you. Viola


#11

Hi…
just wondering if anyone would be able to help me with this please…?
I trying various things but it still doesn’t work… thank you!
Viola


#12

From this image OpenFOAM is not installed correctly on your machine. I’m surprised that it ran in the first place.


#13

Thanks Mostapha, I think I did something btw the first times and these last ones (to solve the no folder 1 and no realistic vectors). I will undo it and I ll go back to the original problem, that I send the first picture about, so vectors appear but are straight and seem not to take in account of the buildings+no folder “1” is created.
Please do you know where the problem could sit in this last case?
As I’m really struggling to get this right so I still can’t work on my final project…
Many thanks in advance,
Viola


#14

Does perhaps my old rhino/gh go in conflict with the latest butterfly by any chance…?

Rhino: 5 SR5 (5.5.30717.16015, 07/17/2013)
Grasshopper: 0.9.0076 (August 27, 2014)
Butterfly: 004, updated as per your suggestion on: https://github.com/ladybug-tools/butterfly/issues/341
OpenFOAM 1712
VM 5.2.12


#15

how do you know it is not installed correctly?


#16

Based on this screenshot:


#17

Hi,
I reinstalled all few times, and now it all seems to work without errors following this (https://github.com/ladybug-tools/butterfly/issues/349) and updating the BF components and folders. Therefore I now have: Latest BF, OF v.1706, VM 5.2.8 and the Docker Toolbox has been automatically updated to 18.05.0-ce. Followed all videos to set ok the VM, so no errors appear anymore anywhere.

However, I still have the same issue with vectors, please can you look at my post:

Many thanks. V.


#18

Are you sure you are trying to visualize velocity vectors?

Also, a simple way to debug this is to check the input of the vector component. Are these velocity vector values being calculated (should be an x,y,z input list)? Also, make sure the results folders are in the case folder. If the study run all the way to the end, the endTime folder (e.g. 1000/) should be there.

Kind regards,
Theodore.


#19

Yes. I see that you figured from the image. I am trying to understand which message led you to believe that OpenFOAM is not installed correctly?

The maximum number of retries (60) exceeded

Is that it?


#20

Hi Theodore,
thank you for answering,

what I am trying to do is first of all replicate Mostapha video 4 on Butterfly (https://www.youtube.com/watch?v=0auA5exoL9M) using the example file you guys provided, to have a first working file and move on from there. Because I installed the latest version of BF, there were some components which I had to update (e.g. automatic grading etc), and I did some other things that I noted in capital letters on the file attached, e.g. detached the refinement grid as per your post to Devang. Not sure if those are causing this or what else, I am now pretty stuck…

Not sure what you mean with the vector velocity part of your answer please…?

Re the folders in the case folder, thay are created until the end but number 1 is not created when the snappy mesh runs, as it is shown on the video, nor I see such a refinement grid around the buildings as I see on the video.

Here attached is the file, few images and the link to my other post where I moved this topic: SnappyHex mesh doesn't seem to work

Many thanks. Viola

180702_01_0_outdoor_airflow_VM2.gh (529.8 KB)

No%20-1-%20folder2018-07-02_073929


Wind Tunnel construction logic
SnappyHex mesh doesn't seem to work