Odd behaviour of the output from the LBT 1.4 Heat map component

I posted this curiosity at the end of another post:

In retrospect, I suspect it should be its own topic.

I have tried the well-known technique of turning off Preview on the HeatMap component and then feeding this into Custom Preview to try to better control and scale the legend. However, there are two issues:

  1. scale affects the mesh, but not the spacing of the text, and
  2. Custom Preview works in Shaded View in Rhino, but not in Rendered View.

Rough example of scaling the legend:

I recommend using the PreviewLW componet from the Human plugin.
Indeed the CustomPreview dowsn’t show in Rendered views. I find the Human component(s) more consistent.
The image below shows the HourlyPlot outputs, but the Heatmap should not be much different.

As for the legend scale i recommend setting all you need with the LegendPar which gives you a lot of options, better than dealing with the individual outputs (nightmare option to do).



Kia ora Abraham

Thanks. My inquiry was essentially focused on assisting a colleague who was looking to use students’ base understanding to ‘bake’ outputs …

Interesting note about legend par - I have been recommending using the legend parameter option, but have never realised / noticed that it offered a base plane for the legend option…