OpenFoam Installation error: ssh command error


Recently when I install the OpenFoam, it is always stuck during the step of “waiting for an IP address”.

Actually, I have successfully installed OpenFoam v1806 on windows 10 before, but 2 days ago when I restarted my laptop, OpenFoam threw me an error as:

Error checking TLS connection: ssh command error:
command : ip addr show
err : exit status 255
output :

Then my nightmare began. I read similar topics in the Forum and tried many solutions, including:

  1. Uninstall everything (docker toolbox, virtualbox, OF and related folders in C:/) and install them following this links and this link again;
  2. Install old version of OpenFoam, v1612+ and v1706;
  3. Install docker toolbox, virtualbox and OF separately, as this link and this link suggested;
  4. Other solutions from several docker forums;

all above are unfortunately failed. the error first appears in the installation of Powershell while waiting for an IP. After the installation is done, the virtual box seems fine. then errors shows again while creating the environtment. The snapshots of error are as follows:

I turned off firewall before installation(the windows defender remains on), and opened every installer as admin, but the error is always there. Now I am pretty confused because it used to work with the OpenFoam v1806 version. Sincerely appreciate for anyone who could figure out how to fix this annoying problem.

Best regards,

Hi, thanks for posting this I have this issue too.
Does enyone could please help us?
Thanks in advanced.

Please try openFOAM version +1612

Hi @devang,
Noting changed I tried OF 1612+.

Did you uninstall everything and then try version 1612+ ?

Yes, I worked with Butterfly before and installed that on many PC.
This is new problem.

Hi, I am sorry for making a slip in writing. What I try is v1612+, not 1606+.
I will modify this info, sorry again for misleading.

Hi, @devang,

Actually, from the 20 times re-installation experience, the problem may have something to do with the IP address in running the .exe file of “OpenCFD-OpenFOAM4WindowsInstaller_v1612+.exe”(or the other version), almost everytime it will stuck in the step of “waiting for an IP” for a long time (although I don’t have VPN and turnoff the firewall, and I even try to connect to different network, home,library, my office), and later the “ssh command error” appears as the snapshot shows, no matter to install Oracle VB or docker tools or OF together or separately.

Just a guess, I know nothing about docker.

I have a similar problem. I also followed the guidelines from this link and several other troubleshooting posts here, but could not identify the issue… I tried multiple other OF versions, and Oracle VM versions, installing them separately before and after etc.

I tried v1612+

Hi Hansbeda,

I have already given up using Butterfly…
The only solution found so far was to reinstall the windows system.



Thank you so much for your answer. I managed to install OpenFoam without problems on a Win7 PC. I am still facing the same issue as described above on Win10. I hope someone finds out what the problem could be.


Dear all,

I am having still the same problems.