OpenFOAM installation

I am using open foam 1804 with latest butterfly tool buts till unable to generate results with latest outdoor example file. I have already tried the open foam 1605 and later versions but all in vain. Please help.

I have also posted this problem in github

Can you try this file? (502.3 KB)

It is compatible with the Github version.

I did a run, but the values were zero. I guess the latest version of open foam is not compatible with butterfly

I use v1612 on windows 10. Works just fine.

I ill just do that thanks.

Also, kindly setup a profile picture.

Sure !!! I will set it up

The 1612 open foam file i downloaded but it says missing image file. The virtual machine is also not starting up. It specify :

Post http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.24/images/load?quiet=0: open //./pipe/docker_engine: The system cannot find the file specified.

You checked this?

And this?

I checked both still unable to install this version. It would be very helpuful if u could test the procedure of installing it

I have used the same procedure to install. Please share screenshots of error

While installing virtual box, it asks f

or an image to download… but it fails to download saying address not found.

this solved the problem to me.


I will get back to you Viola once i try this procedure. Thanks

Are you sure you installed OF1706? Your screenshot shows 1612+.

(Beforehand, make sure you installed Oracle virtual box version 5.2.8 from google you find the way, as the link is not valid anymore, and you unclick the installation of the VM when you install the docker and any other time the window asks you to update the version…)

Plus, remember to follow this, to update to 1706: re the .tar file

Finally, you should install the latest Butterfly. The link on this post for some reason doesn’t work anymore, but first see if OF gets installed, then in Discourse or GitHub there must still be the latest BF version, you can search it or if I find it I’ll post it.


Latest Butterfly:

Hello, Viola and Devang. I have successfully installed the open foam version 1612+ as described by devang.
1st i installed docker toolbox separately and than ran the open foam setup file. This solved my issue. While installing open foam i unchecked docker installation. I updated butterfly and it is good to go now.

Thanks for the valuable input.