OpenStudio error: unsupported operand type(s) for -: 'list' and 'tuple'


I am trying to run a rather complex Geometry with ~50 zones and ~10 zone programs and schedules, so I won´t upload a model for now. The error I am getting is the following one:

  1. Solution exception:unsupported operand type(s) for -: ‘list’ and ‘tuple’

I tried to test run the phython script and I am getting the following errors:

I was also checking the Phython script for the outputs ‘list’ and ‘tuple’, but I have no shading modelled, neiter a PV system, that´s what I could relate these errors to.

FYI: Honeybee, Ladybug and script are freshly updated. I am using OpenStudio 2.7.0 and Rhino 6. The model (geometry) was running before without any errors.

@Jonas ,

Thanks for letting us know. This was a bug that was recently introduced by a check that I had added in order to make sure that window surfaces were being sent correctly into E+. It affected all cases where you were running an energy model that included non-planar geometry, which I imagine you must have somewhere in your large model.

I just fixed the bug:

and this is something that I know a lot of people will experience so I have updated the version of the components on Food4Rhino.

P.S. While you can still get simulations to run in OpenStudio 2.7, I would recommend you use OpenStudio 2.5 for now and you can see the reasons in the release notes for the last stable release.