Pollination "No OpenStudio Installation was found on this machine"


Hi all,

I’ve installed Pollination and used Ladybug components for a while, all works fine.
Today I start jumping into Honeybee however as soon as I connect HB Model to OSM the error message shows as below.
" “No OpenStudio Installation was found on this machine” "

If I understand correctly, the Pollination Grasshopper installer comes with a compatible copy of Radiance and OpenStudio so that users don’t have to install them again or separately?

Here I can find OpenStudio context under my ladybug_tools folder.

Hey @tutu7931 ,

Yes, honeybee should be finding that installation of OpenStudio in Program Files/ladybug_tools that came with the single click installer. What do you get when you use the HB Config component to see all of the current configurations? Are any of them identified correctly?

Hi @chris
Thanks for your reply.

RH6, OSM works:

RH7, OSM doesn’t work:

Can you advise where to start the fixing?

Ok. The issue is likely that your IronPython paths are not set up correctly. The single-click Pollination installer is supposed to fix this for you but I guess it’s not working for some reason. CC: @MingboPeng .

In any event, you can manually fix it by following the first 3 steps of the instructions here BUT instead of just adding the path, you want to make sure that there is only one path to the Ladybug Tools site-packages, which should be:

C:\Program Files\ladybug_tools\python\Lib\site-packages

for your case.

After doing that and restarting Rhino, it should work.

Hi @chris

Below are the IronPython path screen shots of both RH6 & RH7 from my end BEFORE manually adding anythings.

As the start-up message showed on top, the search path you indicated was successfully added for both RH6 & RH7.
C:\Program Files\ladybug_tools\python\Lib\site-packages
But the problem still remain.



:thinking: Hm, that’s really perplexing @tutu7931 .

I have to admit that I really don’t know what is going on since it looks like the same libraries are loaded in each version of Rhino and so they should be able to find the same simulation engines. Can you try doing a fresh reinstallation with the single-click installer?

Hi @chris

In fact I’ve reinstalled with the single-click installer couple times since then, still RH6 is the only way to trigger OpenStudio from my end …

Hey @tutu7931 ,

Looking at this more, it’s kinda like Rhino 7 is completely unable to see certain files on your machine. Can you open this Grasshopper file and post a screenshot of what you see? It should look like this:

installation_test.gh (3.4 KB)

If it doesn’t look exactly like that, can you verify that the file at C:\Program Files\ladybug_tools\python\python.exe actually exists on your machine?



Ok, I think we’re getting close to knowing what’s going on. It looks like the setting of your ladybug_tools_folder might not be correct. I can’t figure out why it would be different between Rhino 6 and 7 but all of the symptoms from your screenshot suggest that the ladybug_tools_folder is not correct in Rhino 7.

Can you try opening the following file in both Rhino 6 and Rhino 7. If everything was correct, the component would look like this in both versions of Rhino:

installation_test2.gh (2.7 KB)

If it doesn’t look like that in both Rhino 6 and 7, you can run the following from command line AS AN ADMINSTRATOR and that should hopefully fix it permanently:

"C:\Program Files\ladybug_tools\python\Scripts\ladybug.exe" set-config ladybug-tools-folder "C:\Program Files\ladybug_tools"

Hi @chris

So indeed my screen looks different as the image shown below:

Then I ran cmd as suggested (as Admin)

However even I ran the cmd line and reopen and check, the GhPython Script shown the same as if it didn’t change, or got alter when the software reopen…

Thanks, @tutu7931 .

I think I probably know what has happened now. The pollination installer is supposed to delete that older installation of Ladybug Tools at:


but I am guessing that the installer could not find it because it’s on the D:\ drive instead of the C:\ drive. CC: @MingboPeng

In any event, I have one last suggestion, which is to just manually delete that folder at:


Hopefully, after that and a restart of Rhino, everything should work. Or, if it doesn’t, we will see exactly what has caused this mismatch between your Rhino 6 and Rhino 7.

Hi @chris

I’ve tried deleted the folders in my D drive, however they are recreated after launch the installation_test py. Please see video below.

Hi @chris
Please see the video below,

After deleting several folders in \AppData\Roaming\McNeel\Rhinoceros\7.0\scripts and run installation_test.py, the output seems normal now.
To be honest I’ve no idea since when those files were existed in there,
I’ll keep testing for other components and see if they all work.

Phew! Glad that we finally got to the bottom of it.

It seems that you must have installed some very old beta version of the LBT plugin before version 1.0 was released since we have not put the libraries into the Rhinoceros\7.0\scripts folder for at least 4 years now. I remember we initially debated putting the libraries there, though, before the LBT 1.0 plugin was complete. So maybe you got a hold of some extremely old installer that wasn’t meant to be released publicly or that we forgot to take donw.

Anyway, glad it’s fixed now.