Questions About the New Single-Click Installer

Kia ora @chris

Exciting as always. As we are on mid-trimester break, this seemed a really interesting option to talk through with our tech support as it offers the solution to multi-user, single computer support (not to mention the many exciting analysis recipes - I am particularly liking the glare mapping without images and sectional view options)

This had me immediatly trialling the installation at home.

The first issue is that I received a warning about the software not being recognised by the Microsoft Defender anti-virus system. I will have to advise student installers about how to deal with this, in the interim. The second issue is that I had to click the following agreement to install what I thought was the free grasshopper option.

I can imagine a certain amount of student fright at this message.

And finally, although you state “Furthermore, when you run this single-click installer, any old versions of Ladybug Tools will be automatically uninstalled, making your life easier.” when I start Grasshopper within Rhino I receive this message:

Replace all seems to ensure that only v1.5 tools appear on the menus, but I will be looking to run uninstall separately.


1 Like

Hi @MichaelDonn ,

I hope you don’t mind that I moved this to a new topic since there are a lot several questions you are asking here that aren’t related to the 1.5 release.

Most operating systems do more hand-holding than is necessary for a typical user. For example, I think you probably get this same Windows Defender message when using the single-click installer for the latest versions of Radiance. We can eventually get this message to go away if we pay a service to get our installers certified but this hasn’t been a priority since most people running the installer know that they can trust our software. If we get more sales of the Pollination CAD plugins, we can pay for this installer certification sooner than later but, for now, just clicking “More Info” and “Run Anyway” hopefully shouldn’t complicate the install process too much.

You are right that it seems we included the license of the Pollination Rhino plugin in the free Pollination Grasshopper installer. I think @MingboPeng should be able to change this when he gets the chance but, in the meantime, I think the heading makes it pretty clear that this license is not for the Pollination Grasshopper plugin but rather for the paid Rhino plugin. So users do not need to worry about the consequences of this particular license if they are only using the Pollination Grasshopper plugin.

I think this one might be specific to your machine but @MingboPeng will know for sure. It’s possible that the single-click installer is only removing old installations of Ladybug Tools and not old installations of the Pollination Grasshopper plugin, in which case, we should add another check for this in the installer.

kia ora @chris

Thanks for taking the time. Placing this in a separate thread makes good sense.

BTW: I liked the simplicity of the single installer, and the matching installation of compatible calculation engines. This will simplify support for home use of LBT by students in our classes. And the single disk location for the software for multi-user desktops is greatly appreciated by our tech support who had devised a workaround that I believe had to be updated with each new release.

Personally, I am failing the intelligence test around how to uninstall v1.4 of LBT…

Hi @MichaelDonn, our installer does remove all old versions when it is allowed to do so with an authorized account. That means if the installer was run by IT or another account other than “OEM”, the installer won’t be able to remove the folder “C:\Users\OEM\pollination” which is under “OEM” user profile. This is the only situation that I could imagine that would cause the conflict issue. If this is not the case, then it is a bug somewhere in the installer, that I will have to dig into.

I will update the license for the Grasshopper plugin.

Thanks again for your feedbacks.

Kia ora @MingboPeng

OEM came about because the desktop at home was built by me.

OEM has full admin privileges. I test and develop at home. I leave the security issues around who I am and what my permissions are to the tech staff who manage that.

So, this occurred at home, where to my knowledge, there have been no permissions issues with this OEM based process in the past even though I sign in to Windows with a Microsoft id.


Thanks @MichaelDonn for confirming the privilege details. Would you mind having a test with the new installer v1.3.5 that I just released?

Kia ora @MingboPeng

Thanks for this. Happy to help.

I have downloaded and run the v1.3.5 installer.

It sat at this point for a long time:

But it finished reporting no errors:
However, it has now frozen here:


Some 5-10 minutes.

There may be a clue here?

I have tried closing Rhino (via Task Manager as everything was frozen).

Then i have run Rhino again.

This time I received the warning

I chose “Try Ägain Right Now”

This brought me back to the window I received last time:

And, prior to the gh interface being accessible, there was one last message, the same as previously encountered:


1 Like

Hi @MichaelDonn, sorry to hear the same error here, could you try to manually remove the folder “C:\Users\OEM\pollination” and open the Rhino again?

1 Like

Kia ora @MingboPeng

That certainly resolved the problem. Components dragged onto the gh workspace have the 1.5.0 tag.

Running the sample file produced the expected result.

Thanks. Not sure if I helped refine the installation process at all.

It being 1:42am, I had better get some sleep - I was fortunately awake puzzling over the Colibri save image issue (Colibri not saving images - Grasshopper - McNeel Forum) when I noted your helpful posts.