Radiance definition

In HB Legacy, we easily added optional texts (Radiance) to the library. But I feel it is not possible in LBT. But maybe I am wrong.
I have also connected the optional text directly from a panel to the input of the modifier, which also encountered an error. What is the solution?

Hi @Aliarch ,

From your screenshot, I am not entirely sure what you are trying to do. That’s not the path the the user standards library and I don’t know if you’re just trying to write that radiance string to your library or if you are looking for a general solution for how to load Modifier objects from Radiance strings.

But, if you just want to add a Radiance modifier into your user standards library, then you can copy that text in the panel into a text file. Then you can save that text file with a .rad or .mat extension in the following location:


Then, the modifier object will be loaded to your library the next time that you start Grasshopper and you can assign the modifier to Honeybee objects using the name of it.

Hi @chris
How should I create the .rad file? I mean, in which software should I put the desired text and save it with the extension .rad?

Just use any text editor. Just change the extension of the file from .txt to .rad.

1 Like

thanks @AbrahamYezioro
exactly my question is here. how should i do this act?

Don’t do it with the properties. Just RENAME (right click on the file) and write RAD instead of TXT at the extension.
I see that you are not showing the extensions in the display. In the folder options uncheck the hide extensions, like so:


1 Like

its done but my system doesn;t has that path Chris has mentioned.


i replace here but dosen’t exist in HB Search Mofidiers

The path that you highlighted in the image doesn’t correspond to the one @chris wrote.
I don’t know what the AAAA file is refering to, but it doesn’t have any extension on it.


in fact this is a radiance material (a translucent).
yes i agree with you; it is not. but that mentioned path does not exist in my computer.
now what should i do?

You probably have the previous LBT installation locations.
I suggest uninstalling and installing again with the free GH installer that you can download here. It will install everything at the right location, where, then, you can find the ath that Chris mentioned.

Good luck,

i reinstalled Lbt and after that the path corrected but still the material does not add to radiance library
do you have any idea?

The file MUST have the extension .rad

1 Like

thank you so much @AbrahamYezioro for your persistence to solve this issue.
finally its done and it worked.

I have a similar issue, I cannot find my modifiers library. I followed Chris route but it is empty, however I can see the list of modifiers in the Grasshopper canvas.
I am trying to import this newly created rad material to my library but it is not visible. Could someone tell me what am I doing wrong?


if you can plaese show me your scripts that has been inputed

Hi @Aliarch the solution has been posted in this other thread.
It was necessary to restart Rhino to see the rad files loaded in the library.

1 Like