Radiation analysis error


I’m using ladybug to do radiation analysis. I’ve previously never had any issues with it until now. Using Rhino 6 and latest plugin updates.

Radiation analysis fails with following error message:
Current document units is in Meters
Conversion to Meters will be applied = 1.000
Radiation study time = 64.283 Seconds…
number of mesh:106819 != number of values:0
Runtime error (MissingMemberException): ‘int’ object has no attribute ‘GetBoundingBox’

line 2772, in calculateBB, “”
line 170, in resultVisualization, “”
line 467, in main, “”
line 493, in script

The geometry I’m using is surfaces, some trimmed some untrimmed.

If I untrim all the analysis surfaces I don’t get the error, but this isn’t ideal as the analysis geometry isn’t representative

Any help would be appreciated.


I also had this issue

Hi @AKomar,
I observed this same error here. Recreating the geometry fixes it. However, it would be good if you can share a sample for us see. If a lot of users experience the same error then we will look into it.

I will also recommend you to take advantage of the LBT plugin where Radiation analysis recipe is available.