Rhino 6 / Grasshopper - Crashing with Honeybee


I’m trying to load “Ladybug Tools 1.4.0” in Rhino 6. The grasshopper and rhino crashes when I tried loading Honeybee.

Prethvi Raj,
Building Performance Analyst,
TRAJECT Adviseurs en Managers.

Hey Prethvi,

You should be a little more specific if you wanna be helped. What do you mean loading Honeybee? Are you executing the installation script? If so, in which step does it crash?

I meant when I place a component from the honeybee tab into the grasshopper canvas both rhino and grasshopper crashes.

Hi -
Please run the Rhino SystemInfo command and copy-paste the result here.

Hi Wim,

System info from Rhino,

Rhino 6 SR34 2021-2-3 (Rhino 6, 6.34.21034.07001, Git hash:master @ 2fec8130f097ca52a8bc9f334c3ed4a5921c5e30)
License type: Commercial, build 2021-02-03
License details: Cloud Zoo. In use by: Prethvi ()

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DELL-PM

Computer platform: LAPTOP - Plugged in [90% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 6-1-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
Primary OpenGL: NVIDIA Quadro P520 (NVidia) Memory: 2GB, Driver date: 11-20-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.66
> Integrated acclerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-20-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”


Hi Prethvi -
Thanks for that information.

Is this a new system / did you just start using it with Rhino or was this working correctly before and the crashing started happening when something changed?

I’m trying to understand if the crashes have something to do with the Ladybug Tools (and, perhaps, version 1.4.0 specifically), or if you are also experiencing crashes when just using Rhino to create models.

When Rhino crashes, does it pop up a crash reporter, and, if so, are you sending that in?

The GPU in your PC is a bit underpowered to be running Rhino but that alone shouldn’t be causing a crash. Do you use your laptop screen as well, in addition to the external screen? If your crashes are more general than just using Honeybee, I’d at least consider updating the drivers for the Quadro P520 card. Don’t rely on Windows tools to check for updates - the Rhino Notifications panel has links to the download page for your card.

Hi Wim,

No, this is not a new system, but we are trying to use honey bee for the first time on this laptop and my colleagues’ laptops as well.

Using just Rhino to make models and any analysis using Ladybug works great, I experience this crash only with Honeybee.

Rhino does not create a popup, it just crashes without any notification. I have updated the driver via Rhino->Notifications, but still, I have the same issue.

Any thoughts?



Hi Prethvi -

I’m afraid not, no. This sounds like something that @chris or @mostapha might have ideas about.
Can you perhaps narrow down which component leads to a crash?
Also, I take it that the Ladybug components that you are using successfully also are from the 1.4.0 release?

Hi Wim,
Thanks for your input. Placing any Honeybee component leads to a crash.

  • Prethvi

I think I might know what is going on. @piac pointed out that our use of subprocess.PIPE could be unstable on some Windows versions for some reason:

Does this LB Cumulative Sky Matrix component also crash Rhino for you, @Prethvi ?

If that’s the case, then we can be pretty confident that this is the problem.

Hi @chris ,

Yes, the Rhino crashes when I tried loading LB Cumulative Sky Matrix.

Hi @chris ,

Also on the other hand I read @piac 's post and tried enabling the (subprocess_test.gh). The grasshopper script works but unfortunately, both Honeybee components and Cumulative Sky Matrix crashes along with Rhino.

In this case, I’m 99% confident that you’re experiencing this issue because of our use of subprocess.PIPE, then.

Can you do another test for me to see if the following file crashes Rhino for you when you enable the component?
subprocess_test_2.gh (3.2 KB)

If everything runs successfully, this is what your canvas should look like.

And, if everything has run successfully, then I’ll be able to fix this problem for you.

It’s also possible that the UUID module might be to blame as described here. Let’s see if the Grasshopper definition above works and, if so, I’ll confirm that the problem isn’t with UUID before I try to fix things.

Hi @chris ,

Please find the following screenshot, after enabling the component.

1 Like

Woohoo! This is looking very promising, then. We just need one final test to rule out the use of UUID as the culprit. Can you try running the following Grasshopper file and send a screenshot of the output?

uuid_test.gh (2.7 KB)

If all is working well, it should look something like this:

Assuming that you’re able to test it and it all works well, I can start implementing a fix across the plugin this weekend.

Hi @chris,
I tried loading the “uuid_test.gh”. Unfortunately, the Rhino and Grasshopper crashes just like before when I tried loading Honey bee components.

I hope this is the result you are expecting.

Did you see the solution fort the other discussion?

What’s the antivirus that you’re using? Can you try the dance component after deactivating the antivirus on your machine?

1 Like

I just wanted to second what Mostapha said. It seems this issue is different than I originally thought and you should try deactivating your antivirus, @Prethvi .

Hi @mostapha ,
We are using SentinelOne and our IT team said it is not possible to turn off this software. However based on the link you shared above, the IT Team added the path to rhino and rhino.exe to the exclusion list. Despite the effort, the Honeybee component is crashing in my system.

Any further ideas or workaround?