Run simulation through openstudio does not work (write does) - Honeybee 0.0.64

openstudio
#1

Dear all,

I have recently update honeybee (to Honeybee 0.0.64) and openstudio (to 2.5). Since this update I have not been able to simulate using the exportToOpenStudio component. The component successful writes the .osm file and when I open and simulate it using OpenStudio everything works fine. The IDF which is written also corresponds with what I expect. exportToOpenStudio does not give any error messages which makes this hard to troubleshoot. The command prompt window just briefly pops up without any output. Does anyone have any thoughts?

Some details:

  • Openstudio is installed at: C:\Program Files\openstudio-2.5.0
  • I checked if installing different components (C, ruby API, parametric part, etc.) of openstudio made a difference as I prefer a light installation. It didn’t.
  • I have removed all user-objects using the remove HB definition from Hydra (also manually checked)
  • Re-installed Honeybee 0.0.64(+ladybug)
  • Re-installed Python for GH
  • The folder C:\ladybug is set to read only but all its contents and subfolder are set to read and write. My organisation does not alow me to set any folder in C: to anything but read-only, and it will be overwritten if I do. I can overwrite this for all folder contents and this has never cause problems before.
  • See GH definition attached
    20190322_Tsk56prtCref_HB_EP_updt.gh (1.0 MB)

Greetings,

Samuel

#2

Hi,@SamueldeVries I have some suggestions for you to improve your model.
1.Update honeybee to version 0.0.64.
2.Re-install Openstudio 2.5.0 to C:\openstudio-2.5.0

#3

Hi @minggangyin,

Sorry I made a mistake in my post. I am using HB 0.0.64.
As for installing OpenStudio at C:\openstudio-2.5.0: I started out installing it there but then HB couldn’t find openstudio. When I install in program files it does and only then does it write the OSM file.

Thank and gr,

Samuel

#4

Hi,@SamueldeVries Maybe you should install Openstudio firstly and install Honeybee secondly.

#5

@minggangyin. Thank you for the tips. I tried both orders in installing. This did not make a difference.

The problem is that there that the batch file which is written by exportToOpenStudio is missing an \ (see below). My python isn’t great but there seems to be an ’ ’ missing in line 5248 of the code. I tried updating to the latest version of HB on github but this did not change the error. If I add an \ before Epl-run things work as they should. The image still says energyplus 8.5 but I changed this to 8.9 by editing my environmental variables (I have multiple versions installed).

@chris is this a bug in the code or does it have to do with my situation?

Some additional info: I am using Rhino 5. I am using Openstudio 2.5.0 because I want to give Ironbug a try.

#6

Hi @SamueldeVries, it seems this error is most likely related to the OpenStudio:

HB would pick up the EnergyPlus that installed with OpenStudio. OpenStudio 2.5.0 has EnergyPlus 8.9 in its directory.
In your case, HB seems failed to find the EnergyPlus in OpenStudio folder, and used the one you installed separately. (Make sure you check the EnergyPlus option when you install the OpenStudio)
image

Mingbo

#7

Hi @MingboPeng. I believe I installed OS 2.5 with EnergyPlus. To be sure I redid the installation with everything included (I believe last time I took out the parametric analyses part). The missing \ was now added correctly but the batch file still wrote out energyplus V8.5 rather then using the version installed with OS. The fails because of this.

I tried going back to OS 2.1 (with EnergyPlus included in the installation, should be 8.7) as I found some mention of this being an officially supported version for the last stable release of HB. Openstudio writes and runs successfully now but still does so using the Energyplus 8.5 I have installed. If I run through OS itself then it uses the 8.7 version installed with OS. (see headers from html below).
Any thoughts?

Using HB:
image

Using OS:
image