Severe ** CheckControllerListOrder: A water coil controller list has the wrong order

openstudio
hvac

#1

Dear all,

Could you please take a look at the attached image and explain the severe error? How should I avoid it?


There are also a number of warnings. Please see the txt file (readme_exportToOpenStudio) :
readme_exportToOpenStudio.txt (12.7 KB)

more details of settings:



#2

@AryanShahabian ,
I think you have found a bug and I am pretty positive that this issue is happening because the fanPlacement is set to True. So a quick way to fix it is to just set it to False.
Nevertheless, if you can upload a file that recreated the issue, I will see if there is a way to fix it (or at least add a warning for this case).


#3

Thank you @chris for your reply.
The error and the warnings are similar to the file I posted before at: Processing Energy Plus outputs. COP and?
A copy of it is also attached here:
Question_AryanShahabian_01.rar (975.9 KB)

(I tried changing the fan placement from true to false but it didn’t remove the error)


Any suggestion about setting old conventional HVAC system (for tall buildings in hot climates)?
#4

Dear @chris , this is just a reminder to follow up if you have probably managed to solve the problem. I appreciate any help you can provide.


#5

@AryanShahabian ,

Sorry for the late response here but the last two weeks have been very busy. I’ll try to have a look when I get the chance. I’m teaching a ladybug workshop this week so it will likely be soon after that.


#6

@AryanShahabian ,

I have tried to answer your question twice but each time, it’s taking so long to run the file that I haven’t gotten around to investigating the solution. If you could post a minimum file that is needed to recreate the issue as the forum guidelines suggest, I might be able to get to a solution more quickly.

It also seems that I am not able to recreate the error on my machine. Your file ran fine using OpenStudio 2.4:

-Chris


#7

Thank you @chris for taking the time to check the file and write the answer.

I installed OpenStudio 2.4 and it tackled the previous severe error. However, I receive 3 new severe errors. readme_OS01.txt (16.6 KB)
For instance:
"
131. ** Severe ** CheckWarmupConvergence: Loads Initialization, Zone=“ZONE_5” did not converge after 25 warmup days.
132.
133. ** ~~~ ** See Warmup Convergence Information in .eio file for details.
134.
135. ** ~~~ ** …Environment(RunPeriod)=“RUN PERIOD 1”
136.
137. ** ~~~ ** …Max Temp Comparison = 1.64E-003 vs Temperature Convergence Tolerance=0.40 - Pass Convergence
138.
139. ** ~~~ ** …Min Temp Comparison = 1.63E-003 vs Temperature Convergence Tolerance=0.40 - Pass Convergence
140.
141. ** ~~~ ** …Max Heat Load Comparison = 0.2519 vs Loads Convergence Tolerance=4.00E-002 - Fail Convergence
142.
143. ** ~~~ ** …Max Cool Load Comparison = 3.8634E-004 vs Loads Convergence Tolerance=4.00E-002 - Pass Convergence
"

I searched for a solution in discourse.ladybug.tools. I also read this, this, this, and this but I’m still not sure what to do. (or just to neglect the errors if they are not really crucial ?)

Should I add “additional string” to the exportToOpenStudio component to alter tolerances before running it? If yes, could you please let me know what should I add exactly?

Regarding posting minimum file:
Actually I had tried to simplify the file as the original file is much larger. I am/was not sure which parts to delete. Maybe for the previous question I could have deleted the constructions but now I guess (please correct me if I’m wrong) the new errors are related to constructions as well; there are pretty thick interior concrete walls in the models, and they should be accurately analysed (due to the aims of the academic research I’m working on; I should model structural walls precisely).

Again, thank you for your time and consideration.

Best,
Aryan