SnappyHex mesh doesn't seem to work

I reinstalled all few times, and now it all seems to work without errors following this ( and updating the BF components and folders. Therefore I now have: Latest BF, OF v.1706, VM 5.2.8 and the Docker Toolbox has been automatically updated to 18.05.0-ce. Followed all videos to set ok the VM, so no errors appear anymore anywhere.

However, I still have the issue of the vectors going straight, and the folder 1 not appearing.

My impression is that the Snappy Mesh is not working correctly, in fact I can’t see the refined mesh when I run it, the folder 1 should be created when SnappyMesh runs and is not, and the vectors seem not to read the buildings at all.

I noticed that with the latest components and the automatic grading the mesh is set very differently (see pictures below), but I don’t know how to change the automatic one, nor to connect the manual (tried but doesn’t seem to work).

I also read this (Butterfly_Wind Tunnel Grading Issue) and tried to detach the refinement region but it is giving me again similar images as beofre, see below the straight vectors.

Please can anyone help me with this?

Thank you.





Are you offsetting your analysis plane from the buildings? Can you share your GH file?

Hi Devang,
many thanks, the file is here: (529.8 KB)

Not sure re the the analysis plane you are mentioning, I tried something but notheing changed (see in capital letters on teh bottom on the file), but the base of this file is the example downloaded to follow video 4…

Please also see the additional notes I wrote in answer to Theodore just now here:

Many thanks.