Solution exception:No file was found at C:\...\openstudio\out.osw

A student of mine is getting this error when running an energy simulation:

Solution exception:No file was found at C:\Users\mimaa\simulation\Model_1_ImportRhino\openstudio\out.osw

When running the command window shell opens and shows like it is running, but it closes too fast that can’t see what is written there.
Surely there is a permission to write BUT she tried also running Rhino as administrator, unfortunately, with the same results.
The installation was done with the GH pollination single-click installer.

Some ideas what can be the cause?


1 Like

Hey @AbrahamYezioro ,

Does the folder of the file listed in the error message actually exist? If so, what is in that folder right now?

It looks like there’s something wrong with the OpenStudio installation such that OpenStudio CLi cannot be launched.

Hi @chris and thanks,
The student should answer your questions above, but just want to say that the installation was done with the one-click installer and it finished fine, so i assume everything was installed as expected.


Hello Chris, Thank you for your help.

The folder openstudio exist at the location of C:\Users\mimaa\simulation\Model_1_ImportRhino\openstudio

attached photo with the content of the library


Hi @chris
attached also the configurations and folders off all plugins

Hi @chris,
Another update: We uninstalled the whole pollination and installed again. Same (bad) result.
The report output of the OS component says the following:

Runtime error (AssertionException): No file was found at C:\Users\mimaa\Documents\TEST\Model_1_ImportRhino\openstudio\out.osw

line 26, in init, “C:\Program Files\ladybug_tools\python\Lib\site-packages\honeybee_energy\result\”
line 229, in script

Running the AnnualLoads component does succeed, giving the simulation results. Our suspicion is that something is happening with the permissions of the OS to run on the computer.
We disabled the antivirus and firewall, but still the full simulation fails.
Worth to mention that the location for both simulations is the same (default), so one goes through and the other doesn’t.
Just to remind from the previous message, we tried also to run Rhino as administrator. No use … :frowning: :sob:

If you have any thoughts/ideas/suggestions … don’t be shy. For now the fast simulations are ok but at some point in the class we are going to use the more detailed results.


Hey @anatst ,

Thanks for the update and sorry for the radio silence. I know a way that you can see the real error if you open a command prompt and paste the following:


If you can send me a screenshot of what you see when you do that, we should be able to nail down the issue.

Also, just to make sure: you’re not running this on Bootcamp with a relatively new Mac, right?

If so, that would explain it. Apple made the decision to use a completely different chip architecture from everyone else in their latest line of laptops, forcing most software to make changes (if you can’t tell by my subtext, I’m trying not to be annoyed by it). If this is actually the issue, then the problem is there has not been a stable release of OpenStudio that works with these new Macs. NREL is slated to make a new release in the next couple of weeks and we’ll update to that once it is available.

Hi @chris,
On this one i can tell that @anat 's computer is a “regular” laptop running windows.

She will send soon the screenshot.

1 Like

  • I had the same problem

Thanks, @architsama_guodong . I am guessing that those characters that you get in response are the real error but I don’t know what it means. Is it translate-able to English?

Hello Chris,

I am having the same issue. This is what appears on the command prompt. Any help with this would be greatly appreciated

Hi All,

We’ve been having a similar issue in our team - not sure if IT related but our process went as follows:

  • Normal install of LBT through food for rhino.

  • Running things normally, until i recieved the same error as above.

  • Followed Radiance blocked post which suggested the Pollination move to program files is the fix (radiance produced similar error)

  • Run smoothly for a couple of days but same error returned (potentially IT induced)

  • Read the HB to OSM component Line 228 - suggesting the idf file isn’t being created properly.

  • Read HB to OSM component Line 38 which has alternative running methods.

  • Changed boolean toggle to integer “3” in a panel and managed to run the simulation okay.

Short workaround - not sure if there are some anomolous results writing and running the simulation this way but a short term fix at least.

@chris - would love a chance for you (or someone else) to give this another look over!


We managed to fix & our IT explained a little bit about what’s happening. Basically a batch file is created in the user’s profile and run in the folder which in turn trips up IT security when a group policy is in place.

The error can be be viewed on MS Windows by going into Event Viewer - Applications and Services Logs - Microsoft - Windows - AppLocker - MSI and Script.


The script was identified as not being signed as secure - and so IT have exempted by folder location through editing the group policy via AppLocker.

This was done by:
Location in group policy – Computer configuration – Windows Settings – Security Settings – Application Control Policies – Script Rules
Exemption type – Path
Folder exemption listed - %OSDRIVE%\USERS*\SIMULATION*\OPENSTUDIO*

Understanding the path rule condition in AppLocker (Windows) | Microsoft Learn

The first wildcard is for the name of the user who is running the script (their profile location). The second is the name of the project that the user created. The last is to allow any scripts in that folder to be run.

Hope this helps people needing a fix in the interim!

Hello all. I realize this thread’s a little dusty, but, I ran into the same error. It happened when I tried shifting my working directory onto an external drive (an SSD on a USB C port; not sure if it’s Thunderbolt). I moved everything back to good ol’ C, and it works (again). I assume the root issue is as identifed by @LeightonSS55 here, and, wow, that’s some troubleshooting you did! Glad I haven’t had to edit group policies…yet.


does somebody know if this is working on parallels windows as well? Tried to integrate this, but perhaps my knowledge of integrating this “Folder exemtion listed” is not enought.

Did somebody accomplished to use radiance on windows parallels on m2/m3 macbook ?

Really need to use it there, because a lot of important plug-ins like Karamba etc. are only avaiable for the windows-GH