Trouble running the set_python_path.bat step of the LBT plugin installation

Hi @chris,

Thank you for the update. I have been using the Ladybug 0.0.68 and Honeybee 0.0.65.
I have follow the instruction to install the 1.1.0 version.

Every thing seems ok, but there were some difference in the process, such as that I have to run the Rhino as administrator to be able run the first installation component, and when I run the set_python_path.bat, the IronPhyton directory was written blank.

The components were successfully appears in the Grasshopper, but all of it were giving red warning saying that it did not find module.

I have try to clean all my LB and HB older version, but the result was still the same.

Is there any solution for this?

I am getting the same issue as @rakhmat.aditra

Initially when I ran the set_python_path.bat file, the IronPython directory was being written to the Rhino 7 folder (under app data), which I was no longer using. Once I uninstalled Rhino 7, the IronPython directory was written blank as shown in the screenshot below.

And I am getting the same problem with the components, where they appear in Grasshopper, but with a red warning saying ___ module not found.

1 Like

I got the same error as @eeshakhanna and @rakhmat.aditra when I use the latest version on Food4rhino.

Previously I managed to install successfully Ladybug in another machine when the version 1.0 was released and then used the “update” component. But now that I tried to install LB in other computers I keep getting the same error.

We have been experiencing the same issue. We found that when having rhino 6 and 7 installed the settings-Scheme files are only copied to the Rhino 7 location -
C:\Users[USERNAME]\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\IronPython\settings

We copied these files
settings-Scheme_Default.xml
settings-Scheme_Inside-Revit-2019.xml
settings-Scheme_Inside-Revit-2020.xml

to this location -
C:\Users[USERNAME]\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\IronPython\settings

and things seem to be working for now.

Will be test driving to verify.

1 Like

For everyone who has run the .bat file but receives a blank/empty space after the Setting the search path in the following file was successful:, I have posted a manual workaround for you:

As I say in the post there, our primary recommendation for this case is to just purchase an executable installer by emailing info@ladybug.tools. But, if you’re just doing the install on one machine have some time to spend, the manual workaround will get you there.

1 Like

Hey Chris, i’m having trouble finding the .bat file? i’m getting weird install error messages that i can’t quite figure out. Any way you can help this one out?

Where would i find the the .bat file? can’t seem to find it in the download at all.

Follow the Installation Instructions, @dbenner .
https://github.com/ladybug-tools/lbt-grasshopper/wiki

Thanks Chris, issue i’m having is i can’t actually see the .bat file anywhere in my ladybug tool folder.

@dbenner ,
Does the 2nd component of the installer.gh tell you that it has written the .bat file in it’s output message? That message should give you the path to where it wrote the .bat file.