URBANopt Error - No results were found at

Hi there,
When running the URBANopt component, I face the following error every time. I also tried to change the location of files including Geojson but again I face with the same error. I don’t know what is wrong with the process. By the way the file I’m working on is exactly the sample file published by Ladybug Official and I also follow exactly the algorithm explained by @chris in his video tutorials. I also have updated ladybug using the latest versioner and installed URBANopt version 0.10.0 but still I don’t know what the problem is.

Here is a screenshot.

Would appreciate if anyone could help.

Hi @Amirgabi ,

I’m sorry that I can’t quite figure out what went wrong since the standard error output from URBANopt does not seem to include the real error of what went wrong. The command was pretty clearly a valid input if it started to produce those warnings like “previous definition of COMMAND_MAP”. Also, I’m not able to recreate the issue on my end and it appears that it is specific to your machine.

Can you try putting the following into the command line and hitting enter?


If you can paste the exact result you get from that to the forum, we might be able to see the real error and push a fix. I’ll also try to get the input from the team at NREL since they may know more about what is happening here.

Hi @Amirgabi ,

I have another suggestion from the team at NREL to help us figure out what is going wrong on your machine. If you could upload the following file from your system, that would allow us to see exactly how the command is running:


Note that the file is hidden by default so, if you don’t have hidden folders showing on your system, you will have to use the full path to upload it here.