URBANopt WindowsError due to System Language Settings

Thank you @chris for all your efforts.
I uninstalled LBT, reinstalled it, and then updated it from LB Versioner. Unfortunately the error still persists; Windows Error
(I was also fully connected to the internet)

Ah, I thought that you were having issues with the OpenDSS component and not the URBANopt component. Are you sure that you are using the compatible version of URBANopt as noted in the Compatibility Matrix? Are you also sure that you are letting the URBANopt simulation run to completion (it will take at least a few minutes when the simulation is successful).

There’s no need to work with the command line at all now.

Thank you @chris for your response.

-At all, this error does not allow the component to run.

Whatever I do, this problem will not be solved, unfortunately. I have been struggling with this problem for almost 15 days.
I have already uninstalled and then reinstalled all Rhino and LBT. But still the problem is not solved. I also followed the compatibility matrix according to the figure below.
( LB versioner also done )

Alright, @Aliarch . I just added a bunch of checks into dragonfly that should be able to tell you what exactly what is wrong with your setup:

Can you try running the LB Versioner, restart Rhino/Grasshopper, and then try running the URBANopt component again? You should get a different error message this time.

I probably should have also asked in the very beginning: you installed URBANopt in its default location, right?

Sorry that this topic originally had the wrong solution labeled and we went down a rabbit hole that had nothing to do with your problem.

Thanks @chris

  • Yes, it is installed on the C drive exactly by default… C:\UrbanOpt-cli-0.6.2

Yes, a new error has appeared that deems the execution of Urban Opt inaccessible.

1. Solution exception:An URBANopt installation was found at C:\UrbanOpt-cli-0.6.2
but the URBANopt executable is not accessible.

I guess there is an incompatibility in Python that is installed on Rhino by default.

Also as more information; I changed the matrix and used the second row of the compatibility matrix;
In fact as follows:

Ah, this is great, @Aliarch . We’re getting much closer to the solution.

So, as you see in the compatibility matrix that you screenshot, you need to be using URBANopt CLI 0.7.1 if you are using the latest development version of Dragonfly (as you are now since you ran the LB Versioner). Not the older URBANopt CLI 0.6.2. So, uninstall your current version of URBANopt CLI and follow the link in the compatibility matrix to get the installer for URBANopt 0.7.1.

I think there’s a strong possibility that this fixes your issue. If you still get the same error after upgrading URBANopt, then I’ll suggest some other things to try.

@chris Unfortunately, the same error still exists
1. Solution exception:An URBANopt installation was found at C:\URBANopt-cli-0.7.1
but the URBANopt executable is not accessible.
The matrix is fully adapted(DEV).also LB versioner is done.
morever, I tried another device, but unfortunately there was still problem.

Ok, we need to get the exact error message that is coming from the .check_uo_version file there. It’s possible that you’ve found a bug in URBANopt that we’ll have to report to NREL. Can you open up the following Grasshopper definition and send me a screenshot?

uo_config_test.gh (6.3 KB)

Whatever is in that last panel is particularly important.

thsnks @chris ; your order :

Ah, so it’s an encoding error. Here’s the explanation as noted by Stackoverflow:

Codepage 720 is Arabic characters used by MS-DOS back in the day, and seems Ruby do not have a translation table for it.

So it’s all related to your operating system’s language settings. I will ask the NREL developers about this to see if they have a suggestion. In the meantime, it might be worth trying some of the things that have solved encoding issues that others have had on their machines. In particular, I think it might be worth trying out this solution that worked for @seghier :crossed_fingers:

Thank you @chris . I think the problem was with the local system. But removing the tick of ^Beta^ did not solve the problem; Instead, with the complete change of the local system to United Stead, the old error was fixed and the component ran.
But unfortunately I encountered a new error.:
1. Solution exception:The URBANopt simulation failed to run.
No results were found at:

I think this time, the problem is the DEV matrix. Is not that so?

1 Like

THANKS @chris ; Your guidance was the solution to the problem; That is, the local system. you are great.

And with a few changes to the keyboard language and also by opening the CSV file at the following address, that new error was fixed.
But the point is, the run time was very long. It took about an hour for the same sample file (from building footprint) without any changes; Is this normal?

Wonderful! Glad to hear that you were finally able to get it to run. I’ll let you know if I hear back from NREL about whether they might be able to get URBANopt to run without having to change your language settings. But I’m glad that you were able to change them for now.

An hour for the simulation to run isn’t that abnormal if your machine only has 2-4 processors and therefore needs to run the energy simulation of each building sequentially (instead of in parallel). I usually run that sample file on my beefy desktop that has more than 14 processors (each with a pretty high GHz). It only takes ~5 minutes to simulate on that machine. I think I ran the sample file once on my 4-CPU laptop and I seem to remember it taking more than a half hour. Long story short, the simulation will be a lot faster if you can run it with a high-quality CPU.

Thanks again for your persistence and patience here.

1 Like

Hi Chris

I am getting this error,
any solution to this you could suggest?

Thank you

Hi Aliarch,
How did you go about changing the local system ??
Thank you

1 Like

Hi @linkimim ,

Your issue is pretty clearly different than the one that @Aliarch was having. In your case, it looks like you do not have the URBANoopt CLI installed at all. Did you install the correct version by following the URBANopt link in the Compatibility Matrix?

Hi Chris,
Yes I Have…
I have downloaded them multiple times…
env-uo.bat file also shows up in my homepath
It used to work but after I tried set too many geos to a brep it crashed.

Perhaps this is where something broke? Maybe you should try deleting the file at:


Then restart Rhino and try running your dragonfly definition again and see if that little component still says it cannot identify the URBANopt CLI (that is what it means when it says it cannot identify uo).