Using three/five phase recipe component

Hello
I had issue running ASE component in HB+. i followed some other topics and updated the ASE based on this post here:

now i am able to run ASE/sDA but only with the annualDLReceipe. when i use both 3/5 phase recipe , it does not work for me. is this an issue with HB+ or its just me not being able to run them ?

Thanks !

I need to know more about the issue that you are facing to be able to help. We wrote a post about the best practices of posting a question on the forum which might be helpful: https://discourse.ladybug.tools/faq

Hi @mostapha , thank you for the reply. please see the screenshots. i am able to use the annual recipe and run it, but it does not work with the 3/5phase. was not sure why this component is not working for me. attached the GH file too. Thank you in advance!



TESTannual.gh (489.7 KB) TESTBOX.3dm (80.5 KB)

Can you copy/paste the error message from the RunRadiance component. I downloaded and ran it on my machine and it worked, so It is hard for me to say what is wrong.

Thank you @m.gilvez for taking the time to look at this. so it run for you with the fivephase? thats the error:
Solution exception:AssertionError and thats what i get from clicking on the component.


There are a few threads on this error (here is one that suggests reinstalling: https://discourse.ladybug.tools/t/hb-assertion-error/8221. It may be the permissions on your machine or something else. Since I was able to run it, it may not be an issue with the script, but rather your installation or how it is configured. Good luck.

based on its python script, i only can use it if I have windows group. hopefully thats the issue.

It’s funny, because I thought that might be the issue, but then i got results when I ran it. Probably best practice to use window groups to define windows in either case. Update if that’s the issue.