HB+ Assertion Error

Hello Everone,
Does anyone know the solution for this error? I am getting an assertion error in Skymatrix. I reinstalled HB and LB. HB + is also updated. still, I am getting this error.
Thank you in advance.

  1. What type of study are you conducting?
  2. Can you run the study using HB legacy?
  3. If you have to use HB+, did you try the version on food4rhino?
  4. Did you take a look at other discussions on the forum? HB+ Assertion Error in Sky Components

Thank you Devang for the response.
I am trying to do a 5-phase simulation. For now, I am using an example file only "11_five_phase_II_gridbased ". For five phase I will need a “sky matrix” only. And I have downloaded from food4rhino.
Yes I checked discussion on HB+ Assertion Error in Sky Components

Does it solve your issue?

No I am still getting same error.

it would help if you can share the file

For now I am trying to run example file only.
11_five_phase_II_gridbased.gh (496.3 KB)

Can you double click on the component and see the full error message? Unfortunately Grasshopper doesn’t show the full assertion error message and it is very hard to say what is going wrong.

Thank you for the response.
For your reference, I have attached a full error message.

This is the code and not the error. Test the code to produce the error (triangle button at the top of the window).
-A.

skymatrix.py (9.2 KB)

@bhattkhushbu

I had the same issue before, but I was able to fix the issue after replacing someone’s entire “scripts” folder. (if you can find someone’s files which work well in his or her computer, copy and paste that person’s files to yours). Please see the folder location below:
C:\Users\yourname\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts

I think you need to have Rhino 6 closed before you copy these in.
I recommend backing up your original folder by renaming it with the -OLD extension.
C:\Users\yourname\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts-OLD

I hope it helps.

Seung

Thank you so much for your response.
That problem got fixed after reinstalling.

I’m facing a similar error

I’m trying to run a three phase simulation with an example file from HERE
Tried checking on different machines but it seems to run into the same error.
would anyone be willing to share their “scripts” folder as per what @seung has suggested?

@sreejithjayaram93

Can you try to remove all and reinstall Ladybug tools?
It may help you to fix your problem. This is on the premise that your grasshopper script is not an issue.