Watch the sky component error

Hello, I’m getting this error from the watch the sky component:

  1. Solution exception:Could not find file ‘C:\Users\zambranoh\AppData\Roaming\Ladybug\skylib\CIESkies\Napa_Co__Airport_CA_USA\CIE_intermNoSun_sky_1_1@100_radAnalysis_skyView.irr’.

I looked in the folder, but the file is not there, HB is probably not creating the file, any idea why? or how to fix it?

Please see file attached. Thank you!

Hi Helena,

It is hard to guess. Is the folder created fine? and by folder I mean C:\Users\zambranoh\AppData\Roaming\Ladybug\skylib\CIESkies\Napa_Co__Airport_CA_USA\

There should be a .bat file inside the folder that you can run manually and see why this is happening.

Also can you generate the image for other weather files?

I suggest you to attach your grasshopper definition instead of the Rhino file.


Hi Mostapha,

The folder was created fine, I just ran the .bat file manually and the .irr file was created in the folder, so it works now. But I’m not sure why honeybee didn’t create the file automatically.

I attached the grasshopper file, just in case.

Thank you!

Helena (553 KB)

Hi Mostapha, I have a similar problem with the HDR Image path for the glare analysis component. I cannot generate the image for any weather files.

The grasshopper file is attached. Thank you! (363 KB)

Hi Helena,

The reason you are not getting the sky image is that you are asking for an hour that there is no sun above the horizon.

See attached.

-A. (364 KB)

Hi Mostapha!

I was also trying to run this component and it seems I have the same problem as Helena:

  1. Solution exception:No se pudo encontrar el archivo ‘C:\Users\Elsa\AppData\Roaming\Ladybug\skylib\CIESkies\MADRID_ESP\CIE_sunnyWSun_sky_6_21@1200_radAnalysis_skyView.irr’.

I attach the GH file as well as an screenshot with the folder, in which there isn’t any file named as “CIE_sunnyWSun_sky_6_21@1200_radAnalysis_skyView.irr”.

Do you have any idea :S? I have tried this file in other computer and it worked out :S

Thanks a lot in advance!!

problem with generate (83.8 KB)

Hi Eli, This was an issue with type of input for imageSize (Integer vs Float). If you connect a panel vs a slider it should work fine. I changed the type to be int. Can you try the attached file and see if it fixes the issue. (89.5 KB)

Sorry, Mostapha,

but it still presents the same problem

  1. Solution exception:No se pudo encontrar el archivo ‘C:\Users\Elsa\AppData\Roaming\Ladybug\skylib\CIESkies\MADRID_ESP\CIE_sunnyWSun_sky_6_21@1300_radAnalysis_skyView.irr’.

Thanks in advance!

It seems that the component called “HBwatchthesky” is not working while creating the files with the extension .irr, not even the HDR. Probably, this component is not finding the specified C:\Radiance path and not even the C:\Users path, as you can see in the image. It is the same file of the other day…

The .sky files are properly created but it seems that “HBwatchthesky” can’t read this files or something like that.

Any idea? Could it be something related to the projectname, part of the name of the final path?

Thanks a lot in advance!

Hi Eli, I think you’re right. The path is already set in batch file so if other components work this should also work.

Let’s try this:

If you go to the folder that the sky is generated (c:\ladybug\skylib\basedOnIlluminanceLevel) is my case.

There should be a batch (*.bat) file in the folder. Right click on bat file and open it as a text file.

  1. Remove first line which is @echo off.

  2. Change the last line from exit to pause.

  3. Now if you save and close the file and double click you should see a window similar to this:

We should be able to see the error there.

Dear Mostapha,

Thank you very much for your answer… strangely, I opened the file in order to check out your solution and it run correctly by itself :S it’s a kind of magic, but it seems everything’s ok for this issue! Thanks again!

Hi Mostapha,
When does the .bat file created by the honeybee component get executed? When I try to run the HDR to GIF component directly from grasshopper it never works, but if I run the .bat file manually from my computer, it works just fine -it creates the .gif file and I can preview it through embryo by copying the file path directly.

The same exact thing is true about the component that creates the .irr file. if I double click the .bat file it works, otherwise, honeybee never creates the .irr file. (499 KB)

Hi, I was trying to follow the Honeybee Workshop to learn how to use the components, but I’m getting a error in the “watch the sky” component:

For some reason the component is having a “access denied” to the 'C:\Users\" (see the attached file). The folder that is shown wasn’t created, and the path that it’s trying to find is different from the rest of the files (they are all in the path ‘C:\Users\tiago.xavier.INOVATECH\AppData\Roaming\Ladybug\skylib\CIESkies\SAO_PAULO_BRA’, as can be seen in the panel in the image).

Do you have any idea whats wrong?

I’m having the same problem as Tiago.
The red baloon reads "Solution exception: Access to path ‘C:…’ was denied.
I, also couldn’t locate this file.
I’ve found this conversation: Honeybee_watch the sky error, but the solution didn’t work on this case.
How can I solve this?

That’s because of the ‘.’ in your username. :expressionless:

This is a bug in the legacy component. If you copy the file to some other folder (e.g. c:\ladybug) and then connect the new path to this component it should work fine.

1 Like