1. Solution exception:Attempted to divide by zero


just updated to the latest version of honeybee and ladybug and am trying to run a daylight analysis and I get the following error when creating the glazing based on ratio:

  1. Solution exception:Attempted to divide by zero.

Not sure if there is a bug or I am doing some sort of dumb mistake!

Thank you,



Use the new update component. It will update all components that keep the input/output structure. Those who doesn’t will be circled in red and the new version will be inserted below the old one so you can just reconnect all inputs/outputs.

For your case i will recommend to reinsert the component.


Thank you Abraham, since the component stated it was from the latest version I didn’t think I had to reinsert it.

All working now:)


I’m getting the same error when I’m modelling a customized geometry in Rhino. It works fine when I use the example file from hydrashare. The Ladybug/Honeybee components are up to date. Any other troubleshooting ideas that could make this work?

Thank you

Mansi Dhanuka

Hi everyone,

I just stumbled upon a similar issue: When generating the LB Test Points (1.2.0) for a generic perimeter block geometry by extruding its base surface i get the error “Solution exception:Attempted to divide by zero.”
The same geometry however works, when it is created through “Solid Difference”.
The Issue can also be resolved by lowering the grid size below 0.25 or above 2.

I am now wondering what’s behind that, it’s not really a big thing, but impedes the workflow a bit.
Is that an issue to be adressed with Ladybug or Grasshopper?


Test Points.gh (14.4 KB)

Hello, I am facing the same issue. I tried all the tips, but still nothing :frowning:

Hello, the same for me here, and with the same version “1.6.0”. @chris and @mostapha do you know what might be the soultion for this issue? (v 1.6.0; R 5.4a 2021-03-28 LBNL (5.4.947ea88a29)).
This issue has cause a lot of drawbacks.

ps: I used the “LB Versioner” component tip, and I even did the excersie with a simple box and the issue still persits.

Thanks in advance

We probably should not be posting issues related to the LBT plugin an a very old LEgacy thread.

If you’re using the Legacy version, it might be anything since there are plenty of bugs in Legacy that could not be fixed but, if you are using LBT, the answer is here:

@chris Thanks for your quick reply.
In first place sorry for posting in a LBT plugin thread instead of a Legacy thread.
In second place, as I mentioned before, I did the simple excersise doing it with a simple box (in the origin) and the issue still persists.
So for what your are saying “If you’re using the Legacy version, it might be anything since there are plenty of bugs in Legacy that could not be fixed” I infer: 1st there is no solution and 2nd Ladybug is currently unable to do an incident radiation analysis (?).

I believe I found a solution. I uninstalled Radiance (version 5.4a 2021-03-28 LBNL (5.4.947ea88a29)) and I installed the latest version (5.4a 2023-08-16 LBNL (5.4.a3a737a923)).
Did the script again, with a simple box, run the LB Incident Radiation component, and finally got no error!.
Hope it owrks for you as well.